aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2022-08-09 00:08:13 +0200
committerJo-Philipp Wich <jo@mein.io>2022-08-09 00:20:09 +0200
commit737671bcceb438195ad8fe78b6f93e5ccfef8483 (patch)
treeb7a76e9c5ca7c3b26b8578e1a8974063a82f364c
parent1bfe42beb463094334e5c753efc9f495591d0b88 (diff)
downloadupstream-737671bcceb438195ad8fe78b6f93e5ccfef8483.tar.gz
upstream-737671bcceb438195ad8fe78b6f93e5ccfef8483.tar.bz2
upstream-737671bcceb438195ad8fe78b6f93e5ccfef8483.zip
jansson: revert ABI version bump
The soversion of the shipped libjansson.so library didn't change, so the ABI version change is unwarranted and leads to opkg file clashes. Also stop shipping an unversioned library symlink while we're at it as it only needed at compile/link time and leading to file level clashes between packages on future ABI bumps. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--package/libs/jansson/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/libs/jansson/Makefile b/package/libs/jansson/Makefile
index 4b0b7601c9..6de48c1d86 100644
--- a/package/libs/jansson/Makefile
+++ b/package/libs/jansson/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=jansson
PKG_VERSION:=2.14
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/akheron/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)?
@@ -33,7 +33,7 @@ define Package/jansson
CATEGORY:=Libraries
TITLE:=Jansson library
URL:=http://www.digip.org/jansson/
- ABI_VERSION:=5
+ ABI_VERSION:=4
endef
define Package/jansson/description
@@ -45,7 +45,7 @@ TARGET_LDFLAGS += -flto
define Package/jansson/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjansson*so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjansson*so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,jansson))