aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2023-01-08 17:30:07 +0100
committerSander Vanheule <sander@svanheule.net>2023-01-24 21:00:19 +0100
commit4db8598e4296054c7ca500fc7efe67fbabda69ca (patch)
treee65456fee67f74be54abe3c2126f80b7d474fe04
parentac21dff5b67698c09f54a4b98d6f9f12af17edd4 (diff)
downloadupstream-4db8598e4296054c7ca500fc7efe67fbabda69ca.tar.gz
upstream-4db8598e4296054c7ca500fc7efe67fbabda69ca.tar.bz2
upstream-4db8598e4296054c7ca500fc7efe67fbabda69ca.zip
realtek: Do not set KERNEL_ENTRY just to avoid NO_EXCEPT_FILL
It seems like we are offsetting the KERNEL_ENTRY to +0x400, which is also accomplished by the NO_EXCEPT_FILL configuration option. Since this is the default for MIPS_GENERIC_KERNEL, lets push a little bit closer to that one by doing the same thing. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
-rw-r--r--target/linux/realtek/image/Makefile1
-rw-r--r--target/linux/realtek/patches-5.10/300-mips-add-rtl838x-platform.patch3
-rw-r--r--target/linux/realtek/patches-5.15/300-mips-add-rtl838x-platform.patch3
3 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 3dfbcf67c1..a2afb39d40 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -4,7 +4,6 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR = 0x80100000
-KERNEL_ENTRY = 0x80100400
DEVICE_VARS += \
CAMEO_BOARD_VERSION \
diff --git a/target/linux/realtek/patches-5.10/300-mips-add-rtl838x-platform.patch b/target/linux/realtek/patches-5.10/300-mips-add-rtl838x-platform.patch
index 3834ba7c61..f54bd28242 100644
--- a/target/linux/realtek/patches-5.10/300-mips-add-rtl838x-platform.patch
+++ b/target/linux/realtek/patches-5.10/300-mips-add-rtl838x-platform.patch
@@ -25,7 +25,7 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
platform-$(CONFIG_SGI_IP28) += sgi-ip22/
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -1037,8 +1037,58 @@ config NLM_XLP_BOARD
+@@ -1037,8 +1037,59 @@ config NLM_XLP_BOARD
This board is based on Netlogic XLP Processor.
Say Y here if you have a XLP based board.
@@ -33,6 +33,7 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
+ bool "Realtek based platforms"
+ select DMA_NONCOHERENT
+ select IRQ_MIPS_CPU
++ select NO_EXCEPT_FILL
+ select SYS_HAS_CPU_MIPS32_R1
+ select SYS_HAS_CPU_MIPS32_R2
+ select SYS_SUPPORTS_BIG_ENDIAN
diff --git a/target/linux/realtek/patches-5.15/300-mips-add-rtl838x-platform.patch b/target/linux/realtek/patches-5.15/300-mips-add-rtl838x-platform.patch
index 3929096888..8428c32e4e 100644
--- a/target/linux/realtek/patches-5.15/300-mips-add-rtl838x-platform.patch
+++ b/target/linux/realtek/patches-5.15/300-mips-add-rtl838x-platform.patch
@@ -25,7 +25,7 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
platform-$(CONFIG_SGI_IP28) += sgi-ip22/
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -1053,8 +1053,58 @@ config NLM_XLP_BOARD
+@@ -1053,8 +1053,59 @@ config NLM_XLP_BOARD
This board is based on Netlogic XLP Processor.
Say Y here if you have a XLP based board.
@@ -33,6 +33,7 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
+ bool "Realtek based platforms"
+ select DMA_NONCOHERENT
+ select IRQ_MIPS_CPU
++ select NO_EXCEPT_FILL
+ select SYS_HAS_CPU_MIPS32_R1
+ select SYS_HAS_CPU_MIPS32_R2
+ select SYS_SUPPORTS_BIG_ENDIAN