aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2023-08-06 21:19:44 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2023-09-16 21:00:38 +0200
commit3c8825e5f8ec46368f36f6c92506860a7bb9bc6b (patch)
treea083df1e0a0e321d13c80f18cfc50726eb072322
parentc79854e9fc8bb3e20c0f22116bbe76ff353a9322 (diff)
downloadupstream-3c8825e5f8ec46368f36f6c92506860a7bb9bc6b.tar.gz
upstream-3c8825e5f8ec46368f36f6c92506860a7bb9bc6b.tar.bz2
upstream-3c8825e5f8ec46368f36f6c92506860a7bb9bc6b.zip
kernel: enable vfio and vfio-pci for armsr-armv8
Arm platforms with the right hardware blocks (such as GICv3.0+ interrupt controller and SMMU/IOMMU) are able to use vfio-pci to pass through PCI devices to a VM. Signed-off-by: Mathew McBride <matt@traverse.com.au> (cherry picked from commit 9ac01aac0a820f2c48b2ab26628a8c90fb005f20)
-rw-r--r--package/kernel/linux/modules/virt.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/virt.mk b/package/kernel/linux/modules/virt.mk
index 6d255cb176..f45cb17614 100644
--- a/package/kernel/linux/modules/virt.mk
+++ b/package/kernel/linux/modules/virt.mk
@@ -77,7 +77,7 @@ $(eval $(call KernelPackage,kvm-amd))
define KernelPackage/vfio
SUBMENU:=Virtualization
TITLE:=VFIO Non-Privileged userspace driver framework
- DEPENDS:=@TARGET_x86_64
+ DEPENDS:=@TARGET_x86_64||TARGET_armsr_armv8
KCONFIG:= \
CONFIG_VFIO \
CONFIG_VFIO_NOIOMMU=n \
@@ -99,7 +99,7 @@ $(eval $(call KernelPackage,vfio))
define KernelPackage/vfio-pci
SUBMENU:=Virtualization
TITLE:=Generic VFIO support for any PCI device
- DEPENDS:=@TARGET_x86_64 @PCI_SUPPORT +kmod-vfio +kmod-irqbypass
+ DEPENDS:=@TARGET_x86_64||TARGET_armsr_armv8 @PCI_SUPPORT +kmod-vfio +kmod-irqbypass
KCONFIG:= \
CONFIG_VFIO_PCI \
CONFIG_VFIO_PCI_IGD=n