aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Böhler <dev@aboehler.at>2023-09-12 19:57:55 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-09-18 11:50:08 +0200
commit385a50f02df4068118e94a742ab7b24c4b8f882b (patch)
tree905d08b37c146f800334b540dc6085eea689c762
parent2dc284a79a0dd5f8a8e4d9422dd12319320ad6db (diff)
downloadupstream-385a50f02df4068118e94a742ab7b24c4b8f882b.tar.gz
upstream-385a50f02df4068118e94a742ab7b24c4b8f882b.tar.bz2
upstream-385a50f02df4068118e94a742ab7b24c4b8f882b.zip
ipq40xx: fix image building for ZTE MF287 series
For the ZTE MF287 series, a special recovery image is built. The Makefile worked fine on snapshot, but created corrupt images on the 23.05 images. By using the appropriate variable, this should be fixed. Signed-off-by: Andreas Böhler <dev@aboehler.at> (cherry picked from commit a9cc3708e0c3c4869711a9ba4b9c1437ed250721)
-rw-r--r--target/linux/ipq40xx/image/generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 7f4806b63d..08cbd63b3c 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -1172,7 +1172,7 @@ define Device/zte_mf287_common
# exploit for the web interface
IMAGES += factory.bin recovery.bin
IMAGE/factory.bin := append-ubi
- IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/openwrt-$$(BOARD)$$(if $$(SUBTARGET),-$$(SUBTARGET))-$$(DEVICE_NAME)-initramfs-zImage.itb rootfs=$$$$@ | append-metadata
+ IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE) rootfs=$$$$@ | append-metadata
endef
define Device/zte_mf287plus