aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-09-05 16:00:42 -0400
committerMichael Pratt <mcpratt@pm.me>2022-09-22 16:48:36 -0400
commit331830af5132f8f5026e73231cdd573f7f31b0ca (patch)
tree6e41d0c0c9ff0473fa1609bb970ab725ea66714b
parentda4609788ddd559d4847662231cded2ecac16549 (diff)
downloadupstream-331830af5132f8f5026e73231cdd573f7f31b0ca.tar.gz
upstream-331830af5132f8f5026e73231cdd573f7f31b0ca.tar.bz2
upstream-331830af5132f8f5026e73231cdd573f7f31b0ca.zip
acx-mac80211: set DL_DIR to package specific subdirectory
This package downloads raw files which have names that are not corresponding to the name and version of the package as it is defined in the Makefile. Use the option DL_SUBDIR to set the DL_DIR to be a subdirectory named with PKG_NAME and PKG_SOURCE_DATE to better organize the downloads. Define PKG_VERSION here using PKG_SOURCE_DATE. Signed-off-by: Michael Pratt <mcpratt@pm.me>
-rw-r--r--package/kernel/acx-mac80211/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/acx-mac80211/Makefile b/package/kernel/acx-mac80211/Makefile
index 8bb84e5a6a..240f171d1e 100644
--- a/package/kernel/acx-mac80211/Makefile
+++ b/package/kernel/acx-mac80211/Makefile
@@ -17,6 +17,8 @@ PKG_SOURCE_DATE:=2014-02-16
PKG_SOURCE_VERSION:=b6fc31491020cb01d2cd1acc170cfa03ced7e726
PKG_MIRROR_HASH:=58590245715f0e5fb4b57aab6d91071dfb6a97d3273f5aee0b97b1edee030ed0
+DL_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_DATE)
+
PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_MAC80211_DEBUGFS \
CONFIG_PACKAGE_MAC80211_MESH \