aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Anisimov <maxim.anisimov.ua@gmail.com>2022-11-11 12:52:38 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-20 16:44:24 +0100
commit21762e46535d154a2e349ae2d646e2ea6926f365 (patch)
treed46e74442fef7bfa55e2d3fa5851f019ed83719f
parenta28297d395d4253c03f362bc1ac1974b0b4f825e (diff)
downloadupstream-21762e46535d154a2e349ae2d646e2ea6926f365.tar.gz
upstream-21762e46535d154a2e349ae2d646e2ea6926f365.tar.bz2
upstream-21762e46535d154a2e349ae2d646e2ea6926f365.zip
ramips: add support for Keenetic KN-3010
Keenetic KN-3010 is a 2.4/5 Ghz band 11ac (Wi-Fi 5) router, based on MT7621DAT. Specification: - System-On-Chip: MT7621DAT - CPU/Speed: 880 MHz - Flash-Chip: Winbond w25q256 - Flash size: 32768 KiB - RAM: 128 MiB - 5x 10/100/1000 Mbps Ethernet - 4x external, non-detachable antennas - UART (J1) header on PCB (115200 8n1) - Wireless No1 (2T2R): MT7603E 2.4 GHz 802.11bgn - Wireless No2 (2T2R): MT7613BE 5 GHz 802.11ac - 4x LED, 2x button, 1x mode switch Notes: - The device supports dual boot mode - The firmware partitions were concatinated into one - The FN button led indicator has been reassigned as the 2.4GHz wifi indicator. Flash instruction: The only way to flash OpenWrt image is to use tftp recovery mode in U-Boot: 1. Configure PC with static IP 192.168.1.2/24 and tftp server. 2. Rename "openwrt-ramips-mt7621-keenetic_kn-3010-squashfs-factory.bin" to "KN-3010_recovery.bin" and place it in tftp server directory. 3. Connect PC with one of LAN ports, press the reset button, power up the router and keep button pressed until power led start blinking. 4. Router will download file from server, write it to flash and reboot. Signed-off-by: Maxim Anisimov <maxim.anisimov.ua@gmail.com>
-rw-r--r--target/linux/ramips/dts/mt7621_keenetic_kn-3010.dts258
-rw-r--r--target/linux/ramips/image/mt7621.mk14
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/01_leds3
3 files changed, 275 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7621_keenetic_kn-3010.dts b/target/linux/ramips/dts/mt7621_keenetic_kn-3010.dts
new file mode 100644
index 0000000000..5a771f139c
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_keenetic_kn-3010.dts
@@ -0,0 +1,258 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "keenetic,kn-3010", "mediatek,mt7621-soc";
+ model = "Keenetic KN-3010";
+
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ label-mac-device = &gmac0;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: power {
+ label = "green:power";
+ gpios = <&gpio 45 GPIO_ACTIVE_HIGH>;
+ };
+
+ internet {
+ label = "green:internet";
+ gpios = <&gpio 46 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi2 {
+ label = "green:wifi2";
+ gpios = <&gpio 47 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wifi5 {
+ label = "green:wifi5";
+ gpios = <&gpio 48 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ fn {
+ label = "fn";
+ gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_0>;
+ };
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 41 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+ };
+
+ virtual_flash {
+ compatible = "mtd-concat";
+ devices = <&firmware1 &firmware2>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x0 0x1ec0000>;
+ };
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "uart3", "sdhci";
+ function = "gpio";
+ };
+};
+
+&xhci {
+ status = "disabled";
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <31000000>;
+
+ partitions: partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-config";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "rf-eeprom";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ firmware1: partition@50000 {
+ label = "firmware_1";
+ reg = <0x50000 0xf60000>;
+ };
+
+ partition@fb0000 {
+ label = "config_1";
+ reg = <0xfb0000 0x40000>;
+ read-only;
+ };
+
+ partition@ff0000 {
+ label = "dump";
+ reg = <0xff0000 0x10000>;
+ read-only;
+ };
+
+ partition@1000000 {
+ label = "u-state";
+ reg = <0x1000000 0x30000>;
+ read-only;
+ };
+
+ partition@1030000 {
+ label = "u-config_res";
+ reg = <0x1030000 0x10000>;
+ read-only;
+ };
+
+ partition@1040000 {
+ label = "rf-eeprom_res";
+ reg = <0x1040000 0x10000>;
+ read-only;
+ };
+
+ firmware2: partition@1050000 {
+ label = "firmware_2";
+ reg = <0x1050000 0xf60000>;
+ };
+
+ partition@1fb0000 {
+ label = "config_2";
+ reg = <0x1fb0000 0x40000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&mdio {
+ ethphy0: ethernet-phy@0 {
+ reg = <0>;
+ };
+};
+
+&gmac0 {
+ nvmem-cells = <&macaddr_factory_4>;
+ nvmem-cell-names = "mac-address";
+};
+
+&gmac1 {
+ status = "okay";
+ label = "wan";
+ phy-handle = <&ethphy0>;
+
+ nvmem-cells = <&macaddr_factory_28>;
+ nvmem-cell-names = "mac-address";
+};
+
+&switch0 {
+ ports {
+ port@1 {
+ status = "okay";
+ label = "lan1";
+ };
+
+ port@2 {
+ status = "okay";
+ label = "lan2";
+ };
+
+ port@3 {
+ status = "okay";
+ label = "lan3";
+ };
+
+ port@4 {
+ status = "okay";
+ label = "lan4";
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0000>;
+ ieee80211-freq-limit = <2400000 2500000>;
+ };
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0400>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
+
+&factory {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_factory_4: macaddr@4 {
+ reg = <0x4 0x6>;
+ };
+
+ macaddr_factory_28: macaddr@28 {
+ reg = <0x28 0x6>;
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 81ee50e0af..943fc62ecd 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1216,6 +1216,20 @@ define Device/jcg_y2
endef
TARGET_DEVICES += jcg_y2
+define Device/keenetic_kn-3010
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 31488k
+ DEVICE_VENDOR := Keenetic
+ DEVICE_MODEL := KN-3010
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | pad-to $$$$(BLOCKSIZE) | \
+ check-size | zyimage -d 8400912 -v "KN-3010"
+endef
+TARGET_DEVICES += keenetic_kn-3010
+
define Device/lenovo_newifi-d1
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
index 9bac8228a0..42e50451e3 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
@@ -75,6 +75,9 @@ dlink,dir-882-r1)
gnubee,gb-pc2)
ucidef_set_led_netdev "ethyellow" "ethyellow" "orange:ethyellow" "ethyellow" "link tx rx"
;;
+keenetic,kn-3010)
+ ucidef_set_led_netdev "internet" "internet" "green:internet" "wan"
+ ;;
linksys,e5600)
ucidef_set_led_netdev "wan" "wan link" "blue:wan" "wan" "link"
;;