aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2023-02-17 14:03:46 -0800
committerChristian Lamparter <chunkeey@gmail.com>2023-05-18 17:11:43 +0200
commit1f5f17798a33ce9d8aca9f2f0c6192046e5c5807 (patch)
tree2d801c800b0b0af17f22a268e4d264a7f2edfcd8
parent43af3c94be51f086a6f8831a0b46bb3e250c75ac (diff)
downloadupstream-1f5f17798a33ce9d8aca9f2f0c6192046e5c5807.tar.gz
upstream-1f5f17798a33ce9d8aca9f2f0c6192046e5c5807.tar.bz2
upstream-1f5f17798a33ce9d8aca9f2f0c6192046e5c5807.zip
imx: image: ventana: add blkdev compressed disk image
Add a ventana-img.gz compressed disk image to support squashfs+ext4 on a block storage device such as USB/MMC/SATA. The Ventana bootloader expects the bootscript to be boot/6x_bootscript-ventana therefore we must create a bootfs that matches this. Signed-off-by: Tim Harvey <tharvey@gateworks.com>
-rw-r--r--target/linux/imx/image/cortexa9.mk26
1 files changed, 25 insertions, 1 deletions
diff --git a/target/linux/imx/image/cortexa9.mk b/target/linux/imx/image/cortexa9.mk
index 78079aa746..2edbbaac47 100644
--- a/target/linux/imx/image/cortexa9.mk
+++ b/target/linux/imx/image/cortexa9.mk
@@ -52,6 +52,29 @@ define Build/apalis-emmc
$(Build/imx-combined-image-clean)
endef
+define Build/ventana-img
+ rm -rf $@.boot
+ mkdir -p $@.boot/boot
+ $(CP) $(IMAGE_KERNEL) $@.boot/boot/uImage
+ $(foreach dts,$(DEVICE_DTS), \
+ $(CP) \
+ $(DTS_DIR)/$(dts).dtb \
+ $@.boot/boot/;
+ )
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
+ -n '$(DEVICE_ID) OpenWrt bootscript' \
+ -d bootscript-$(DEVICE_NAME) \
+ $@.boot/boot/6x_bootscript-ventana
+ cp $@ $@.fs
+
+ $(SCRIPT_DIR)/gen_image_generic.sh $@ \
+ $(CONFIG_TARGET_KERNEL_PARTSIZE) \
+ $@.boot \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
+ $@.fs \
+ 1024
+ $(Build/imx-combined-image-clean)
+endef
define Device/Default
PROFILES := Default
@@ -99,10 +122,11 @@ define Device/gateworks_ventana
kmod-sound-soc-imx-sgtl5000 kmod-can kmod-can-flexcan kmod-can-raw \
kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio kobs-ng
KERNEL += | boot-overlay
- IMAGES := nand.ubi bootfs.tar.gz dtb
+ IMAGES := img.gz nand.ubi bootfs.tar.gz dtb
IMAGE/nand.ubi := append-ubi
IMAGE/bootfs.tar.gz := bootfs.tar.gz
IMAGE/dtb := install-dtb
+ IMAGE/img.gz := append-rootfs | pad-extra 128k | ventana-img | gzip
UBINIZE_PARTS = boot=$$(KDIR_KERNEL_IMAGE).boot.ubifs=15
PAGESIZE := 2048
BLOCKSIZE := 128k