aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2022-02-24 05:47:11 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2022-02-28 10:24:17 +0800
commit0225df1ec8570d144a0a8d7862036c532cc44dbd (patch)
tree57845b0cdfec5737f1df9b7a8fa3ce6f4895433b
parent4f443c885dede3331b969e6265a41a0ff1e3059a (diff)
downloadupstream-0225df1ec8570d144a0a8d7862036c532cc44dbd.tar.gz
upstream-0225df1ec8570d144a0a8d7862036c532cc44dbd.tar.bz2
upstream-0225df1ec8570d144a0a8d7862036c532cc44dbd.zip
netfilter: add kmod-nft-socket
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
-rw-r--r--include/netfilter.mk2
-rw-r--r--package/kernel/linux/modules/netfilter.mk11
2 files changed, 13 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 751fabef19..83455cc378 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -351,6 +351,8 @@ $(eval $(if $(NF_KMOD),$(call nf_add,NFT_FIB,CONFIG_NFT_FIB_IPV6, $(P_V6)nft_fib
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_QUEUE,CONFIG_NFT_QUEUE, $(P_XT)nft_queue),))
+$(eval $(if $(NF_KMOD),$(call nf_add,NFT_SOCKET,CONFIG_NFT_SOCKET, $(P_XT)nft_socket),))
+
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_COMPAT,CONFIG_NFT_COMPAT, $(P_XT)nft_compat),))
# userland only
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 85780306f3..7200af769f 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -1217,6 +1217,17 @@ endef
$(eval $(call KernelPackage,nft-queue))
+define KernelPackage/nft-socket
+ SUBMENU:=$(NF_MENU)
+ TITLE:=Netfilter nf_tables socket support
+ DEPENDS:=+kmod-nft-core +kmod-nf-socket
+ FILES:=$(foreach mod,$(NFT_SOCKET-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_SOCKET-m)))
+ KCONFIG:=$(KCONFIG_NFT_SOCKET)
+endef
+
+$(eval $(call KernelPackage,nft-socket))
+
define KernelPackage/nft-compat
SUBMENU:=$(NF_MENU)
TITLE:=Netfilter nf_tables compat support