aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2022-08-01 13:30:39 +0900
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-19 22:58:12 +0200
commit00ddd29b650b45cd89f6423dca3eafcc134b7319 (patch)
tree03b65206a1512261b3579f3f1b5a0db2fe51d2d3
parenta80e198cd383593da7f41857a6122f28ed6354a1 (diff)
downloadupstream-00ddd29b650b45cd89f6423dca3eafcc134b7319.tar.gz
upstream-00ddd29b650b45cd89f6423dca3eafcc134b7319.tar.bz2
upstream-00ddd29b650b45cd89f6423dca3eafcc134b7319.zip
build: move Build/edimax-header to image-commands.mk
To use from the following devices in ath79 target, move edimax-header to image-commands.mk. - ELECOM WRC-300GHBK2-I - ELECOM WRC-1750GHBK2-I/C Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
-rw-r--r--include/image-commands.mk5
-rw-r--r--target/linux/ramips/image/Makefile5
2 files changed, 5 insertions, 5 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 6b4bc4945c..492e6933f1 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -218,6 +218,11 @@ define Build/copy-file
cat "$(1)" > "$@"
endef
+define Build/edimax-header
+ $(STAGING_DIR_HOST)/bin/mkedimaximg -i $@ -o $@.new $(1)
+ @mv $@.new $@
+endef
+
define Build/elecom-product-header
$(eval product=$(word 1,$(1)))
$(eval fw=$(if $(word 2,$(1)),$(word 2,$(1)),$@))
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index d48b220231..0992d6ba9f 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -28,11 +28,6 @@ LOADER_FLASH_START := $(ldrflashstart-y)
KERNEL_DTB = kernel-bin | append-dtb | lzma
-define Build/edimax-header
- $(STAGING_DIR_HOST)/bin/mkedimaximg -i $@ -o $@.new $(1)
- @mv $@.new $@
-endef
-
define Build/jcg-header
$(STAGING_DIR_HOST)/bin/jcgimage -v $(1) \
$(if $(JCG_MAXSIZE), -m $$(($(subst k, * 1024,$(JCG_MAXSIZE)))),) \