aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2022-12-17 12:50:52 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-07 17:11:00 +0100
commitfc9dd3f0834317ceb20700fd7033987695661097 (patch)
tree688161e30b659a56e94f98e9a72ba2d0d8be6381
parent3410f010a20a60e9fc47a280fdfdc2dc8fa0e447 (diff)
downloadupstream-fc9dd3f0834317ceb20700fd7033987695661097.tar.gz
upstream-fc9dd3f0834317ceb20700fd7033987695661097.tar.bz2
upstream-fc9dd3f0834317ceb20700fd7033987695661097.zip
mt76: add stand-alone MT7915 firmware package
The mt7915e driver supports MT7915, MT7916 and MT7986 chips. And Only MT7915 series chips need the MT7915 firmware. To save storage, extract them from the common code package and create a new package to provide the firmware. Signed-off-by: Shiji Yang <yangshiji66@qq.com>
-rw-r--r--package/kernel/mt76/Makefile9
-rw-r--r--target/linux/mediatek/image/mt7622.mk20
-rw-r--r--target/linux/ramips/image/mt7621.mk36
3 files changed, 36 insertions, 29 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 4d0575ab3b..874c40766f 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -218,6 +218,12 @@ define KernelPackage/mt7663u
AUTOLOAD:=$(call AutoProbe,mt7663u)
endef
+define KernelPackage/mt7915-firmware
+ $(KernelPackage/mt76-default)
+ TITLE:=MediaTek MT7915 firmware
+ DEPENDS+=+kmod-mt7915e
+endef
+
define KernelPackage/mt7915e
$(KernelPackage/mt76-default)
TITLE:=MediaTek MT7915e wireless driver
@@ -461,7 +467,7 @@ define KernelPackage/mt7663-firmware-sta/install
$(1)/lib/firmware/mediatek
endef
-define KernelPackage/mt7915e/install
+define KernelPackage/mt7915-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/mediatek
cp \
$(PKG_BUILD_DIR)/firmware/mt7915_wa.bin \
@@ -526,6 +532,7 @@ $(eval $(call KernelPackage,mt7663-firmware-sta))
$(eval $(call KernelPackage,mt7663-usb-sdio))
$(eval $(call KernelPackage,mt7663u))
$(eval $(call KernelPackage,mt7663s))
+$(eval $(call KernelPackage,mt7915-firmware))
$(eval $(call KernelPackage,mt7915e))
$(eval $(call KernelPackage,mt7916-firmware))
$(eval $(call KernelPackage,mt7986-firmware))
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 9760097ee4..d90207e464 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -158,7 +158,7 @@ define Device/elecom_wrc-x3200gst3
elecom-wrc-gs-factory WRC-X3200GST3 0.00 -N | \
append-string MT7622_ELECOM_WRC-X3200GST3
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
endef
TARGET_DEVICES += elecom_wrc-x3200gst3
@@ -169,7 +169,7 @@ define Device/linksys_e8450
DEVICE_ALT0_MODEL := RT3200
DEVICE_DTS := mt7622-linksys-e8450
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-mt7915e kmod-usb3
+ DEVICE_PACKAGES := kmod-mt7915-firmware kmod-usb3
endef
TARGET_DEVICES += linksys_e8450
@@ -182,7 +182,7 @@ define Device/linksys_e8450-ubi
DEVICE_ALT0_VARIANT := UBI
DEVICE_DTS := mt7622-linksys-e8450-ubi
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-mt7915e kmod-usb3
+ DEVICE_PACKAGES := kmod-mt7915-firmware kmod-usb3
UBINIZE_OPTS := -E 5
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -233,7 +233,7 @@ define Device/ruijie_rg-ew3200gx-pro
DEVICE_MODEL := RG-EW3200GX PRO
DEVICE_DTS := mt7622-ruijie-rg-ew3200gx-pro
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
endef
TARGET_DEVICES += ruijie_rg-ew3200gx-pro
@@ -242,7 +242,7 @@ define Device/reyee_ax3200-e5
DEVICE_MODEL := AX3200 E5
DEVICE_DTS := mt7622-reyee-ax3200-e5
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
endef
TARGET_DEVICES += reyee_ax3200-e5
@@ -263,7 +263,7 @@ define Device/ubnt_unifi-6-lr-v1
DEVICE_DTS_CONFIG := config@1
DEVICE_DTS := mt7622-ubnt-unifi-6-lr-v1
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-mt7915e kmod-leds-ubnt-ledbar
+ DEVICE_PACKAGES := kmod-mt7915-firmware kmod-leds-ubnt-ledbar
SUPPORTED_DEVICES += ubnt,unifi-6-lr
endef
TARGET_DEVICES += ubnt_unifi-6-lr-v1
@@ -274,7 +274,7 @@ define Device/ubnt_unifi-6-lr-v1-ubootmod
DEVICE_VARIANT := v1 U-Boot mod
DEVICE_DTS := mt7622-ubnt-unifi-6-lr-v1-ubootmod
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-mt7915e kmod-leds-ubnt-ledbar
+ DEVICE_PACKAGES := kmod-mt7915-firmware kmod-leds-ubnt-ledbar
KERNEL := kernel-bin | lzma
KERNEL_INITRAMFS_SUFFIX := -recovery.itb
KERNEL_INITRAMFS := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | pad-to 64k
@@ -294,7 +294,7 @@ define Device/ubnt_unifi-6-lr-v2
DEVICE_DTS_CONFIG := config@1
DEVICE_DTS := mt7622-ubnt-unifi-6-lr-v2
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
endef
TARGET_DEVICES += ubnt_unifi-6-lr-v2
@@ -304,7 +304,7 @@ define Device/ubnt_unifi-6-lr-v2-ubootmod
DEVICE_VARIANT := v2 U-Boot mod
DEVICE_DTS := mt7622-ubnt-unifi-6-lr-v2-ubootmod
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
KERNEL := kernel-bin | lzma
KERNEL_INITRAMFS_SUFFIX := -recovery.itb
KERNEL_INITRAMFS := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | pad-to 64k
@@ -324,7 +324,7 @@ define Device/xiaomi_redmi-router-ax6s
DEVICE_DTS := mt7622-xiaomi-redmi-router-ax6s
DEVICE_DTS_DIR := ../dts
BOARD_NAME := xiaomi,redmi-router-ax6s
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
UBINIZE_OPTS := -E 5
IMAGES += factory.bin
BLOCKSIZE := 128k
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 45ff52be35..037b81992d 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -306,7 +306,7 @@ define Device/asus_rt-ax53u
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | \
check-size
- DEVICE_PACKAGES := kmod-mt7915e kmod-usb3 uboot-envtools \
+ DEVICE_PACKAGES := kmod-mt7915-firmware kmod-usb3 uboot-envtools \
kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += asus_rt-ax53u
@@ -367,7 +367,7 @@ define Device/belkin_rt1800
IMAGE_SIZE := 49152k
DEVICE_VENDOR := Belkin
DEVICE_MODEL := RT1800
- DEVICE_PACKAGES := kmod-mt7915e kmod-usb3 uboot-envtools
+ DEVICE_PACKAGES := kmod-mt7915-firmware kmod-usb3 uboot-envtools
UBINIZE_OPTS := -E 5
KERNEL_LOADADDR := 0x82000000
KERNEL := kernel-bin | relocate-kernel 0x80001000 | lzma | \
@@ -431,7 +431,7 @@ define Device/cudy_m1800
DEVICE_MODEL := M1800
IMAGE_SIZE := 16064k
UIMAGE_NAME := R17
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
endef
TARGET_DEVICES += cudy_m1800
@@ -474,7 +474,7 @@ define Device/cudy_x6
DEVICE_VENDOR := Cudy
DEVICE_MODEL := X6
UIMAGE_NAME := R13
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
endef
TARGET_DEVICES += cudy_x6
@@ -881,7 +881,7 @@ define Device/h3c_tx180x
KERNEL := $$(KERNEL_INITRAMFS) | h3c-blank-header
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
DEVICE_VENDOR := H3C
- DEVICE_PACKAGES := kmod-mt7915e uboot-envtools
+ DEVICE_PACKAGES := kmod-mt7915-firmware uboot-envtools
endef
define Device/h3c_tx1800-plus
@@ -918,7 +918,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
haier-sim_wr1800k-factory
endif
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
- DEVICE_PACKAGES := kmod-mt7915e uboot-envtools
+ DEVICE_PACKAGES := kmod-mt7915-firmware uboot-envtools
endef
define Device/haier_har-20s2u1
@@ -1161,7 +1161,7 @@ define Device/iptime_ax2004m
check-size | iptime-crc32 ax2004m
DEVICE_VENDOR := ipTIME
DEVICE_MODEL := AX2004M
- DEVICE_PACKAGES := kmod-mt7915e kmod-usb3
+ DEVICE_PACKAGES := kmod-mt7915-firmware kmod-usb3
endef
TARGET_DEVICES += iptime_ax2004m
@@ -1207,7 +1207,7 @@ define Device/jcg_q20
check-size
DEVICE_VENDOR := JCG
DEVICE_MODEL := Q20
- DEVICE_PACKAGES := kmod-mt7915e uboot-envtools
+ DEVICE_PACKAGES := kmod-mt7915-firmware uboot-envtools
endef
TARGET_DEVICES += jcg_q20
@@ -1649,7 +1649,7 @@ define Device/netgear_wax202
$(Device/dsa-migration)
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := WAX202
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
NETGEAR_ENC_MODEL := WAX202
NETGEAR_ENC_REGION := US
BLOCKSIZE := 128k
@@ -1866,7 +1866,7 @@ define Device/tenbay_t-mb5eu-v01
DEVICE_VENDOR := Tenbay
DEVICE_MODEL := T-MB5EU-V01
DEVICE_DTS_CONFIG := config@1
- DEVICE_PACKAGES += kmod-mt7915e kmod-usb3
+ DEVICE_PACKAGES += kmod-mt7915-firmware kmod-usb3
KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
IMAGE_SIZE := 15808k
SUPPORTED_DEVICES += mt7621-dm2-t-mb5eu-v01-nor
@@ -1900,7 +1900,7 @@ define Device/totolink_x5000r
UIMAGE_NAME := C8343R-9999
DEVICE_VENDOR := TOTOLINK
DEVICE_MODEL := X5000R
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
endef
TARGET_DEVICES += totolink_x5000r
@@ -1962,7 +1962,7 @@ define Device/tplink_eap615-wall-v1
$(Device/tplink-safeloader)
DEVICE_MODEL := EAP615-Wall
DEVICE_VARIANT := v1
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
TPLINK_BOARD_ID := EAP615-WALL-V1
KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb | pad-to 64k
KERNEL_INITRAMFS := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd
@@ -2095,7 +2095,7 @@ define Device/ubnt_unifi-6-lite
DEVICE_MODEL := UniFi 6 Lite
DEVICE_DTS_CONFIG := config@1
DEVICE_DTS_LOADADDR := 0x87000000
- DEVICE_PACKAGES += kmod-mt7603 kmod-mt7915e
+ DEVICE_PACKAGES += kmod-mt7603 kmod-mt7915-firmware
KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
IMAGE_SIZE := 15424k
endef
@@ -2353,7 +2353,7 @@ define Device/xiaomi_mi-router-cr660x
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
IMAGE/firmware.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | \
check-size
- DEVICE_PACKAGES += kmod-mt7915e uboot-envtools
+ DEVICE_PACKAGES += kmod-mt7915-firmware uboot-envtools
endef
define Device/xiaomi_mi-router-cr6606
@@ -2428,7 +2428,7 @@ define Device/yuncore_ax820
IMAGE_SIZE := 15808k
DEVICE_VENDOR := YunCore
DEVICE_MODEL := AX820
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
endef
TARGET_DEVICES += yuncore_ax820
@@ -2438,7 +2438,7 @@ define Device/yuncore_fap640
IMAGE_SIZE := 15808k
DEVICE_VENDOR := YunCore
DEVICE_MODEL := FAP640
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
endef
TARGET_DEVICES += yuncore_fap640
@@ -2448,7 +2448,7 @@ define Device/yuncore_fap690
IMAGE_SIZE := 15808k
DEVICE_VENDOR := YunCore
DEVICE_MODEL := FAP690
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915-firmware
endef
TARGET_DEVICES += yuncore_fap690
@@ -2611,7 +2611,7 @@ define Device/zyxel_nwa-ax
PAGESIZE := 2048
KERNEL_SIZE := 8192k
UBINIZE_OPTS := -E 5
- DEVICE_PACKAGES := kmod-mt7915e uboot-envtools zyxel-bootconfig
+ DEVICE_PACKAGES := kmod-mt7915-firmware uboot-envtools zyxel-bootconfig
KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
IMAGES += factory.bin ramboot-factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | zyxel-nwa-fit