aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon M. Busch-George <leon@georgemail.eu>2022-11-12 19:31:41 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-06 19:22:52 +0100
commitf6d394e9f2fd41547236c092ac914322220eb77c (patch)
tree30c0f239fdb9e0404f4be23d8390d07f69c2ed1d
parented7c1a504eae6b220e01da330c62c47d299e2c5d (diff)
downloadupstream-f6d394e9f2fd41547236c092ac914322220eb77c.tar.gz
upstream-f6d394e9f2fd41547236c092ac914322220eb77c.tar.bz2
upstream-f6d394e9f2fd41547236c092ac914322220eb77c.zip
ramips: add support for Cudy M1800
Specifications SoC: MT7621 CPU: 880 MHz Flash: 32 MiB RAM: 256 MiB WLAN: MT7915 WiFi 6 (2.4/5 GHz) Ethernet: 2x Gbit ports MAC LAN b4:4b:d6:2e:c7:b0 (label) WAN b4:4b:d6:2e:c7:b1 WiFi 2.4 00:0c:43:26:46:08 WiFi 5 00:0c:43:26:59:97 Installation There are two known options: 1) The Luci-based UI. 2) Press and hold the reset button during power up. The router will request 'recovery.bin' from a TFTP server at 192.168.1.88. Both options require a signed firmware binary. The openwrt image supplied by cudy is signed and can be used to install unsigned images. Signed-off-by: Leon M. Busch-George <leon@georgemail.eu>
-rw-r--r--target/linux/ramips/dts/mt7621_cudy_m1800.dts177
-rw-r--r--target/linux/ramips/image/mt7621.mk10
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/02_network9
3 files changed, 192 insertions, 4 deletions
diff --git a/target/linux/ramips/dts/mt7621_cudy_m1800.dts b/target/linux/ramips/dts/mt7621_cudy_m1800.dts
new file mode 100644
index 0000000000..314fdb206c
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_cudy_m1800.dts
@@ -0,0 +1,177 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "cudy,m1800", "mediatek,mt7621-soc";
+ model = "Cudy M1800";
+
+ aliases {
+ led-boot = &led_internet_white;
+ led-failsafe = &led_internet_white;
+ led-running = &led_internet_white;
+ led-upgrade = &led_internet_white;
+ label-mac-device = &gmac0;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_internet_white: internet-white {
+ label = "white:internet";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ };
+
+ internet-red {
+ label = "red:internet";
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&gmac0 {
+ nvmem-cells = <&macaddr_bdinfo_de00>;
+ nvmem-cell-names = "mac-address";
+ mac-address-increment = <1>;
+};
+
+&gmac1 {
+ status = "okay";
+ label = "lan";
+ phy-handle = <&ethphy4>;
+
+ nvmem-cells = <&macaddr_bdinfo_de00>;
+ nvmem-cell-names = "mac-address";
+};
+
+&mdio {
+ ethphy4: ethernet-phy@4 {
+ reg = <4>;
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0000>;
+ mediatek,disable-radar-background;
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <50000000>;
+ m25p,fast-read;
+ broken-flash-reset;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+
+ partition@1000000 {
+ label = "app";
+ reg = <0x1000000 0xfd0000>;
+ read-only;
+ };
+
+ partition@1fd0000 {
+ label = "debug";
+ reg = <0x1fd0000 0x10000>;
+ read-only;
+ };
+
+ partition@1fe0000 {
+ label = "backup";
+ reg = <0x1fe0000 0x10000>;
+ read-only;
+ };
+
+ partition@1ff0000 {
+ label = "bdinfo";
+ reg = <0x1ff0000 0x10000>;
+ read-only;
+
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_bdinfo_de00: macaddr@de00 {
+ reg = <0xde00 0x6>;
+ };
+ };
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "jtag", "uart3";
+ function = "gpio";
+ };
+};
+
+&switch0 {
+ ports {
+ port@3 {
+ status = "okay";
+ label = "wan";
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 1b4e1dc039..2fc193634b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -426,6 +426,16 @@ define Device/bolt_arion
endef
TARGET_DEVICES += bolt_arion
+define Device/cudy_m1800
+ $(Device/dsa-migration)
+ DEVICE_VENDOR := Cudy
+ DEVICE_MODEL := M1800
+ IMAGE_SIZE := 16064k
+ UIMAGE_NAME := R17
+ DEVICE_PACKAGES := kmod-mt7915e
+endef
+TARGET_DEVICES += cudy_m1800
+
define Device/cudy_wr1300-v1
$(Device/dsa-migration)
IMAGE_SIZE := 15872k
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index f0ac4f1c4f..dea433dec4 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -78,6 +78,11 @@ ramips_setup_interfaces()
uci add_list firewall.@zone[1].network='eth_data'
uci add_list firewall.@zone[1].network='eth_om'
;;
+ cudy,m1800|\
+ yuncore,ax820|\
+ zyxel,nt7101)
+ ucidef_set_interfaces_lan_wan "lan" "wan"
+ ;;
gnubee,gb-pc1)
ucidef_set_interface_lan "ethblack ethblue"
;;
@@ -117,10 +122,6 @@ ramips_setup_interfaces()
ubnt,usw-flex)
ucidef_set_interface_lan "lan1 lan2 lan3 lan4 lan5"
;;
- yuncore,ax820|\
- zyxel,nr7101)
- ucidef_set_interfaces_lan_wan "lan" "wan"
- ;;
zyxel,wap6805)
ucidef_set_interface_lan "lan1 lan2 lan3 lan4"
ucidef_set_interface "qtn" ifname "eth1" protocol "static" ipaddr "1.1.1.1" netmask "255.255.255.0"