aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2023-08-14 06:13:28 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2023-08-19 15:11:55 +0200
commitcebed31c1f632f7fbab142574ea1fb9065917fdb (patch)
tree8511ab153c69fbef6c12a8333a90674007c7b5cc
parent3c316f3e24458eb00c25fc610444186b21c8cf65 (diff)
downloadupstream-cebed31c1f632f7fbab142574ea1fb9065917fdb.tar.gz
upstream-cebed31c1f632f7fbab142574ea1fb9065917fdb.tar.bz2
upstream-cebed31c1f632f7fbab142574ea1fb9065917fdb.zip
armsr: armv8: fix invalid symbol value for FSL_ENETC_QOS
The kernel FSL_ENETC_QOS option is only a compile time option, it does not result in a separate module being built. Set it to 'y' to resolve a warning from the kernel compile: .config:2654:warning: symbol value 'm' invalid for FSL_ENETC_QOS Signed-off-by: Mathew McBride <matt@traverse.com.au> Fixes: c3151b6f045 ("armvirt: 64: add support for other SystemReady-compatible vendors") (cherry picked from commit 7770d08e2bd28c9c0dc0b3dc0aaf74074ad5772a)
-rw-r--r--target/linux/armsr/modules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/armsr/modules.mk b/target/linux/armsr/modules.mk
index c594017ec0..9c7fe0c04f 100644
--- a/target/linux/armsr/modules.mk
+++ b/target/linux/armsr/modules.mk
@@ -100,7 +100,7 @@ define KernelPackage/fsl-enetc-net
KCONFIG:= \
CONFIG_FSL_ENETC \
CONFIG_FSL_ENETC_VF \
- CONFIG_FSL_ENETC_QOS
+ CONFIG_FSL_ENETC_QOS=y
FILES:= \
$(LINUX_DIR)/drivers/net/ethernet/freescale/enetc/fsl-enetc.ko \
$(LINUX_DIR)/drivers/net/ethernet/freescale/enetc/fsl-enetc-vf.ko \