aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2022-10-22 02:26:05 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-22 02:31:57 +0200
commitb9b0407901f6518a0f5c4825208cff542f4b80cd (patch)
tree5fdc940d3ca84b274c2820a6c7c8fe91843216ae
parent1ea3510c5c68048cad65b355beaced1671056a02 (diff)
downloadupstream-b9b0407901f6518a0f5c4825208cff542f4b80cd.tar.gz
upstream-b9b0407901f6518a0f5c4825208cff542f4b80cd.tar.bz2
upstream-b9b0407901f6518a0f5c4825208cff542f4b80cd.zip
kernel: x86: Add glue_helper.ko only on kernel < 5.12
This module was removed with kernel 5.12. This fixes the build of the x86 target. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--package/kernel/linux/modules/crypto.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index f8af5f0a3b..83048e50d3 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -727,10 +727,10 @@ ifndef CONFIG_TARGET_x86_64
FILES+= \
$(LINUX_DIR)/arch/x86/crypto/twofish-i586.ko \
$(LINUX_DIR)/arch/x86/crypto/serpent-sse2-i586.ko \
- $(LINUX_DIR)/arch/x86/crypto/glue_helper.ko \
+ $(LINUX_DIR)/arch/x86/crypto/glue_helper.ko@lt5.12 \
$(LINUX_DIR)/crypto/cryptd.ko \
$(LINUX_DIR)/crypto/crypto_simd.ko
- AUTOLOAD+= $(call AutoLoad,10,cryptd glue_helper \
+ AUTOLOAD+= $(call AutoLoad,10,cryptd glue_helper@lt5.12 \
serpent-sse2-i586 twofish-i586 blowfish_generic)
endef
endif