aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-05-08 18:09:23 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 03:15:41 +0200
commitade9eba1496bb01acc03731c4ccb5369802b73ac (patch)
treedae3310dee4cdb87cd440c285640de25b23301bc
parentc7bca5883d17ad49c66e7acd671c2c2a3d0ea6fc (diff)
downloadupstream-ade9eba1496bb01acc03731c4ccb5369802b73ac.tar.gz
upstream-ade9eba1496bb01acc03731c4ccb5369802b73ac.tar.bz2
upstream-ade9eba1496bb01acc03731c4ccb5369802b73ac.zip
ipq806x: 5.15: drop arm override compile patch
Drop arm override compile patch. The use is dubious and at times (2016) it was never explained why this was required. Krait CPU and Cortex-a15 may be similar but they have some intrinsic difference. While very similar they differ a lot in additional feature and also cache configuration. Also these conflict with raid6 libraty compilation that use specific workaround not compatible with cortex-a15 and produce compilation warning. Fix compilation warning: cc1: error: switch '-mcpu=cortex-a15' conflicts with switch '-march=armv7-a+simd' [-Werror] cc1: all warnings being treated as errors Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
-rw-r--r--target/linux/ipq806x/patches-5.15/0065-arm-override-compiler-flags.patch21
1 files changed, 0 insertions, 21 deletions
diff --git a/target/linux/ipq806x/patches-5.15/0065-arm-override-compiler-flags.patch b/target/linux/ipq806x/patches-5.15/0065-arm-override-compiler-flags.patch
deleted file mode 100644
index a1a0371fbc..0000000000
--- a/target/linux/ipq806x/patches-5.15/0065-arm-override-compiler-flags.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 4d8e29642661397a339ac3485f212c6360445421 Mon Sep 17 00:00:00 2001
-From: John Crispin <john@phrozen.org>
-Date: Thu, 9 Mar 2017 09:33:32 +0100
-Subject: [PATCH 65/69] arm: override compiler flags
-
-Signed-off-by: John Crispin <john@phrozen.org>
----
- arch/arm/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/arch/arm/Makefile
-+++ b/arch/arm/Makefile
-@@ -61,7 +61,7 @@ KBUILD_CFLAGS += $(call cc-option,-fno-i
- # macro, but instead defines a whole series of macros which makes
- # testing for a specific architecture or later rather impossible.
- arch-$(CONFIG_CPU_32v7M) =-D__LINUX_ARM_ARCH__=7 -march=armv7-m
--arch-$(CONFIG_CPU_32v7) =-D__LINUX_ARM_ARCH__=7 -march=armv7-a
-+arch-$(CONFIG_CPU_32v7) =-D__LINUX_ARM_ARCH__=7 -mcpu=cortex-a15
- arch-$(CONFIG_CPU_32v6) =-D__LINUX_ARM_ARCH__=6 -march=armv6
- # Only override the compiler option if ARMv6. The ARMv6K extensions are
- # always available in ARMv7