aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Baumann <felix.bau@gmx.de>2023-07-04 01:35:43 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-08-11 12:53:34 +0200
commitac34f6469ecf07cdeb32f65788192262fd8e0100 (patch)
tree262ff6cabed957fc2fc2020d7c8ff64d41cff51f
parent1a33e4b9520153de44ca3dfb9b1e9819f18cac65 (diff)
downloadupstream-ac34f6469ecf07cdeb32f65788192262fd8e0100.tar.gz
upstream-ac34f6469ecf07cdeb32f65788192262fd8e0100.tar.bz2
upstream-ac34f6469ecf07cdeb32f65788192262fd8e0100.zip
ath79: move ubnt-xm 64M RAM boards back to generic
return ubnt_rocket-m and ubnt_powerbridge-m back to ath79-generic They have enough RAM-ressources to not be considered as tiny. This reverts the commit f4415f7635164ec07ddc22f56df93555804b5767 partially Signed-off-by: Felix Baumann <felix.bau@gmx.de> (cherry picked from commit 9e86a96af5ecea6e73fa463d6cfa4408e2b49d35)
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/01_leds4
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom4
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk18
-rw-r--r--target/linux/ath79/image/tiny-ubnt.mk18
-rw-r--r--target/linux/ath79/tiny/base-files/etc/board.d/01_leds4
-rw-r--r--target/linux/ath79/tiny/base-files/etc/board.d/02_network8
-rw-r--r--target/linux/ath79/tiny/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom4
8 files changed, 33 insertions, 31 deletions
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 2ee4ed2544..b5cc4abf65 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -485,7 +485,9 @@ ubnt,bullet-m-xw|\
ubnt,nanostation-loco-m-xw|\
ubnt,nanostation-m-xw|\
ubnt,powerbeam-m2-xw|\
-ubnt,powerbeam-m5-xw)
+ubnt,powerbeam-m5-xw|\
+ubnt,powerbridge-m|\
+ubnt,rocket-m)
ucidef_set_rssimon "wlan0" "200000" "1"
ucidef_set_led_rssi "rssilow" "RSSILOW" "red:link1" "wlan0" "1" "100"
ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "orange:link2" "wlan0" "26" "100"
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 4f535f8a64..0d7396a04d 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -110,7 +110,9 @@ ath79_setup_interfaces()
ubnt,powerbeam-5ac-gen2|\
ubnt,powerbeam-m2-xw|\
ubnt,powerbeam-m5-xw|\
+ ubnt,powerbridge-m|\
ubnt,rocket-5ac-lite|\
+ ubnt,rocket-m|\
ubnt,unifiac-lite|\
ubnt,unifiac-lr|\
ubnt,unifiac-mesh|\
@@ -785,6 +787,8 @@ ath79_setup_macs()
wan_mac=$(mtd_get_mac_text mac 0x18)
label_mac=$wan_mac
;;
+ ubnt,powerbridge-m|\
+ ubnt,rocket-m|\
ubnt,unifi)
label_mac=$(cat /sys/class/ieee80211/phy0/macaddress)
;;
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
index c46573ece5..f4c2b26d68 100644
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
@@ -109,6 +109,10 @@ case "$FIRMWARE" in
tplink,tl-wr842n-v1)
caldata_extract "art" 0x1000 0x3e0
;;
+ ubnt,powerbridge-m|\
+ ubnt,rocket-m)
+ caldata_extract "art" 0x1000 0x1000
+ ;;
wd,mynet-n600|\
wd,mynet-n750)
caldata_extract "art" 0x5000 0x440
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 0f70649d03..fa4daa3aaa 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -158,6 +158,15 @@ define Device/ubnt_powerbeam-m5-xw
endef
TARGET_DEVICES += ubnt_powerbeam-m5-xw
+define Device/ubnt_powerbridge-m
+ $(Device/ubnt-xm)
+ SOC := ar7241
+ DEVICE_MODEL := PowerBridge M
+ DEVICE_PACKAGES += rssileds
+ SUPPORTED_DEVICES += bullet-m
+endef
+TARGET_DEVICES += ubnt_powerbridge-m
+
define Device/ubnt_rocket-5ac-lite
$(Device/ubnt-xc)
SOC := qca9558
@@ -167,6 +176,15 @@ define Device/ubnt_rocket-5ac-lite
endef
TARGET_DEVICES += ubnt_rocket-5ac-lite
+define Device/ubnt_rocket-m
+ $(Device/ubnt-xm)
+ SOC := ar7241
+ DEVICE_MODEL := Rocket M
+ DEVICE_PACKAGES += rssileds
+ SUPPORTED_DEVICES += rocket-m
+endef
+TARGET_DEVICES += ubnt_rocket-m
+
define Device/ubnt_routerstation_common
DEVICE_PACKAGES := -kmod-ath9k -wpad-basic-mbedtls -uboot-envtools kmod-usb-ohci \
kmod-usb2 fconfig
diff --git a/target/linux/ath79/image/tiny-ubnt.mk b/target/linux/ath79/image/tiny-ubnt.mk
index 0733371441..77940ed875 100644
--- a/target/linux/ath79/image/tiny-ubnt.mk
+++ b/target/linux/ath79/image/tiny-ubnt.mk
@@ -70,21 +70,3 @@ define Device/ubnt_nanostation-loco-m
DEFAULT := n
endef
TARGET_DEVICES += ubnt_nanostation-loco-m
-
-define Device/ubnt_powerbridge-m
- $(Device/ubnt-xm)
- SOC := ar7241
- DEVICE_MODEL := PowerBridge M
- DEVICE_PACKAGES += rssileds
- SUPPORTED_DEVICES += bullet-m
-endef
-TARGET_DEVICES += ubnt_powerbridge-m
-
-define Device/ubnt_rocket-m
- $(Device/ubnt-xm)
- SOC := ar7241
- DEVICE_MODEL := Rocket M
- DEVICE_PACKAGES += rssileds
- SUPPORTED_DEVICES += rocket-m
-endef
-TARGET_DEVICES += ubnt_rocket-m
diff --git a/target/linux/ath79/tiny/base-files/etc/board.d/01_leds b/target/linux/ath79/tiny/base-files/etc/board.d/01_leds
index 92c4499580..07e48ec49f 100644
--- a/target/linux/ath79/tiny/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/tiny/base-files/etc/board.d/01_leds
@@ -116,9 +116,7 @@ ubnt,bullet-m-ar7241|\
ubnt,nanobridge-m|\
ubnt,nanostation-loco-m|\
ubnt,nanostation-m|\
-ubnt,picostation-m|\
-ubnt,powerbridge-m|\
-ubnt,rocket-m)
+ubnt,picostation-m)
ucidef_set_rssimon "wlan0" "200000" "1"
ucidef_set_led_rssi "rssilow" "RSSILOW" "red:link1" "wlan0" "1" "100"
ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "orange:link2" "wlan0" "26" "100"
diff --git a/target/linux/ath79/tiny/base-files/etc/board.d/02_network b/target/linux/ath79/tiny/base-files/etc/board.d/02_network
index 4f6e2918a4..836d119867 100644
--- a/target/linux/ath79/tiny/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/tiny/base-files/etc/board.d/02_network
@@ -54,9 +54,7 @@ ath79_setup_interfaces()
ubnt,bullet-m-ar7241|\
ubnt,nanobridge-m|\
ubnt,picostation-m|\
- ubnt,nanostation-loco-m|\
- ubnt,powerbridge-m|\
- ubnt,rocket-m)
+ ubnt,nanostation-loco-m)
ucidef_set_interface_lan "eth0"
;;
engenius,enh202-v1)
@@ -135,9 +133,7 @@ ath79_setup_macs()
ubnt,nanobridge-m|\
ubnt,nanostation-loco-m|\
ubnt,nanostation-m|\
- ubnt,picostation-m|\
- ubnt,powerbridge-m|\
- ubnt,rocket-m)
+ ubnt,picostation-m)
label_mac=$(cat /sys/class/ieee80211/phy0/macaddress)
;;
tplink,tl-wr941-v2|\
diff --git a/target/linux/ath79/tiny/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom b/target/linux/ath79/tiny/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
index 792c503ab7..d424b9fe2c 100644
--- a/target/linux/ath79/tiny/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
+++ b/target/linux/ath79/tiny/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
@@ -43,9 +43,7 @@ case "$FIRMWARE" in
ubnt,nanobridge-m|\
ubnt,nanostation-loco-m|\
ubnt,nanostation-m|\
- ubnt,picostation-m|\
- ubnt,powerbridge-m|\
- ubnt,rocket-m)
+ ubnt,picostation-m)
caldata_extract "art" 0x1000 0x1000
;;
pqi,air-pen)