aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Norris <computersforpeace@gmail.com>2023-02-04 16:35:34 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-18 19:58:22 +0100
commita79abd813da1976ef3ff2093973b7dae7a90882c (patch)
tree27d28f15601df3ff94a185f7fc1ed6ba68eebe16
parenta3adbec37061e56e7161f28140272cdd86b1dc38 (diff)
downloadupstream-a79abd813da1976ef3ff2093973b7dae7a90882c.tar.gz
upstream-a79abd813da1976ef3ff2093973b7dae7a90882c.tar.bz2
upstream-a79abd813da1976ef3ff2093973b7dae7a90882c.zip
ipq806x: chromium: Enable kmod-ramoops by default
Chromium devices (like OnHub) have ramoops memory reserved by the bootloader. Let's enable the ramoops kernel module by default, so we get better crash logging. Signed-off-by: Brian Norris <computersforpeace@gmail.com>
-rw-r--r--target/linux/ipq806x/image/chromium.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/chromium.mk b/target/linux/ipq806x/image/chromium.mk
index f908472419..ba98929976 100644
--- a/target/linux/ipq806x/image/chromium.mk
+++ b/target/linux/ipq806x/image/chromium.mk
@@ -35,10 +35,14 @@ define Device/OnhubImage
IMAGES := factory.bin sysupgrade.bin
IMAGE/factory.bin := cros-gpt | append-kernel-part | append-rootfs
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ # Note: Chromium/Depthcharge-based bootloaders insert a reserved-memory
+ # ramoops node into the Device Tree automatically, so we can use
+ # kmod-ramoops.
DEVICE_PACKAGES := ath10k-firmware-qca988x-ct e2fsprogs kmod-fs-ext4 losetup \
partx-utils mkf2fs kmod-fs-f2fs \
ucode kmod-google-firmware kmod-tpm-i2c-infineon \
- kmod-sound-soc-ipq8064-storm kmod-usb-storage
+ kmod-sound-soc-ipq8064-storm kmod-usb-storage \
+ kmod-ramoops
endef
define Device/asus_onhub