aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2022-11-17 23:02:13 +0100
committerDavid Bauer <mail@david-bauer.net>2023-01-07 01:32:58 +0100
commit8036fb8dd01d86a1822efd7bdfac3352d97a7657 (patch)
treeeb6539d75e4f03b886f312a927b939bbb595e880
parenteded295cd7fd53bfa5afcb67a1b91cfda0523ba6 (diff)
downloadupstream-8036fb8dd01d86a1822efd7bdfac3352d97a7657.tar.gz
upstream-8036fb8dd01d86a1822efd7bdfac3352d97a7657.tar.bz2
upstream-8036fb8dd01d86a1822efd7bdfac3352d97a7657.zip
ramips: combine USW-Flex dual firmware-partitions
In order to maximize the available space on USW-Flex boards using a dual-image partition layout, combine the two OS partitions into a single partition. This allows users to access more usable space for additional packages. Don't limit the usable image size to the size of a single OS partition. The initial installation has to be done with an older version of OpenWrt in case the generated image exceeds the space of a single kernel partition in the future. Signed-off-by: David Bauer <mail@david-bauer.net>
-rw-r--r--target/linux/ramips/dts/mt7621_ubnt_usw-flex.dts8
-rw-r--r--target/linux/ramips/image/mt7621.mk2
2 files changed, 3 insertions, 7 deletions
diff --git a/target/linux/ramips/dts/mt7621_ubnt_usw-flex.dts b/target/linux/ramips/dts/mt7621_ubnt_usw-flex.dts
index e148242387..ff328bd858 100644
--- a/target/linux/ramips/dts/mt7621_ubnt_usw-flex.dts
+++ b/target/linux/ramips/dts/mt7621_ubnt_usw-flex.dts
@@ -164,14 +164,10 @@
};
partition@1a0000 {
+ /* Combine kernel0 / kernel1 */
compatible = "denx,fit";
label = "firmware";
- reg = <0x1a0000 0x730000>;
- };
-
- partition@8d0000 {
- label = "kernel1";
- reg = <0x8d0000 0x730000>;
+ reg = <0x1a0000 0xe60000>;
};
};
};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 2fc193634b..dd49583bf4 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2130,7 +2130,7 @@ define Device/ubnt_usw-flex
DEVICE_DTS_CONFIG := config@1
DEVICE_DTS_LOADADDR := 0x87000000
KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
- IMAGE_SIZE := 7360k
+ IMAGE_SIZE := 14720k
endef
TARGET_DEVICES += ubnt_usw-flex