aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Hoffmann <jan@3e8.eu>2023-01-05 22:36:24 +0100
committerSander Vanheule <sander@svanheule.net>2023-01-07 11:16:59 +0100
commit7c574525eef49f56f9e9880a1584b3f8d12bcf60 (patch)
treeef0ff8e6dc9eb3e2ced773d41e8c273404c1c841
parent9ac377d0e012e42d9cd69ccc6471fae93c738c1d (diff)
downloadupstream-7c574525eef49f56f9e9880a1584b3f8d12bcf60.tar.gz
upstream-7c574525eef49f56f9e9880a1584b3f8d12bcf60.tar.bz2
upstream-7c574525eef49f56f9e9880a1584b3f8d12bcf60.zip
realtek: don't relocate kernel on HPE 1920 series
This is no longer needed now that the kernel is built with a load address that matches the one hard-coded in the bootloader. Signed-off-by: Jan Hoffmann <jan@3e8.eu>
-rw-r--r--target/linux/realtek/image/Makefile14
-rw-r--r--target/linux/realtek/image/common.mk2
2 files changed, 0 insertions, 16 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 82390212e6..3dfbcf67c1 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -71,20 +71,6 @@ define Build/h3c-vfs
mv $@.new $@
endef
-define Build/relocate-kernel
- rm -rf $@.relocate
- $(CP) ../../generic/image/relocate $@.relocate
- $(MAKE) -j1 -C $@.relocate KERNEL_ADDR=$(KERNEL_LOADADDR) LZMA_TEXT_START=0x82000000 \
- CROSS_COMPILE=$(TARGET_CROSS)
- ( \
- dd if=$@.relocate/loader.bin bs=32 conv=sync && \
- perl -e '@s = stat("$@"); print pack("N", @s[7])' && \
- cat "$@" \
- ) > "$@.new"
- mv "$@.new" "$@"
- rm -rf $@.relocate
-endef
-
define Device/Default
PROFILES = Default
KERNEL := \
diff --git a/target/linux/realtek/image/common.mk b/target/linux/realtek/image/common.mk
index 8f536bf15f..214683f8e9 100644
--- a/target/linux/realtek/image/common.mk
+++ b/target/linux/realtek/image/common.mk
@@ -34,14 +34,12 @@ define Device/hpe_1920
KERNEL := \
kernel-bin | \
append-dtb | \
- relocate-kernel | \
7z | \
h3c-image | \
h3c-vfs
KERNEL_INITRAMFS := \
kernel-bin | \
append-dtb | \
- relocate-kernel | \
7z | \
h3c-image
IMAGE/sysupgrade.bin := \