aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-08-11 14:16:08 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-08-13 16:30:14 +0100
commit79d669d1b7282e2647225936fd5697bba58b55f6 (patch)
tree47522ba92295673e39181d7dfa01f32531b16089
parentdd00bcb43ec5097ac354bc5eebeb72634164b1db (diff)
downloadupstream-79d669d1b7282e2647225936fd5697bba58b55f6.tar.gz
upstream-79d669d1b7282e2647225936fd5697bba58b55f6.tar.bz2
upstream-79d669d1b7282e2647225936fd5697bba58b55f6.zip
armsr: remove redundant phy-marvell-10g module
the Marvell 10G PHY driver is no way specific to ARM SystemReady systems, it frequently occurs on SFP+ copper modules and is useful on many targets. Hence it been added to package/kernel/linux/modules/netdevices and we can remove the now redundant target-specific module. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit c524a76f4c09a4e3fa4572612d336b4ef7ff2fb8)
-rw-r--r--target/linux/armsr/modules.mk11
1 files changed, 0 insertions, 11 deletions
diff --git a/target/linux/armsr/modules.mk b/target/linux/armsr/modules.mk
index 86acc8c4c7..8b026093ee 100644
--- a/target/linux/armsr/modules.mk
+++ b/target/linux/armsr/modules.mk
@@ -151,17 +151,6 @@ endef
$(eval $(call KernelPackage,marvell-mdio))
-define KernelPackage/phy-marvell-10g
- SUBMENU:=$(NETWORK_DEVICES_MENU)
- TITLE:=Marvell Alaska 10G PHY driver
- DEPENDS:=@(TARGET_armsr_armv8) +kmod-libphy
- KCONFIG:=CONFIG_MARVELL_10G_PHY
- FILES=$(LINUX_DIR)/drivers/net/phy/marvell10g.ko
- AUTOLOAD=$(call AutoLoad,35,marvell10g)
-endef
-
-$(eval $(call KernelPackage,phy-marvell-10g))
-
define KernelPackage/mvneta
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Marvell Armada 370/38x/XP/37xx network driver