aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarol Przybylski <karol.przybylski@esm-technology.pl>2023-02-14 23:32:56 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-18 16:23:31 +0100
commit71a22ef17563fd2e55f68c0b93be4a4ec1b00a48 (patch)
treeefccea4dafbc218086982268f1a010da5058f9ae
parent8ef81b4a19a38e9f545dc8e50fff7cc114b48e1a (diff)
downloadupstream-71a22ef17563fd2e55f68c0b93be4a4ec1b00a48.tar.gz
upstream-71a22ef17563fd2e55f68c0b93be4a4ec1b00a48.tar.bz2
upstream-71a22ef17563fd2e55f68c0b93be4a4ec1b00a48.zip
ipq807x: Add bluetooth driver to zyxel nbg7815
Zyxel NBG7815 supports bluetooth with blsp1_uart3. Configuration are already added to dts file, device needs only module to working bluetooth properly. Tested at below posts: https://forum.openwrt.org/t/openwrt-support-for-armor-g5-nbg7815/98598/259?u=itork Reviewed-by: Robert Marko <robimarko@gmail.com> Signed-off-by: Karol Przybylski <karol.przybylski@esm-technology.pl>
-rw-r--r--target/linux/ipq807x/image/generic.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ipq807x/image/generic.mk b/target/linux/ipq807x/image/generic.mk
index 38770a5f24..88d16cc7b2 100644
--- a/target/linux/ipq807x/image/generic.mk
+++ b/target/linux/ipq807x/image/generic.mk
@@ -141,6 +141,7 @@ define Device/zyxel_nbg7815
IMAGES += factory.bin sysupgrade.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to 64k | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := ipq-wifi-zyxel_nbg7815 kmod-ath11k-pci e2fsprogs kmod-fs-ext4 losetup kmod-hwmon-tmp103
+ DEVICE_PACKAGES := ipq-wifi-zyxel_nbg7815 kmod-ath11k-pci e2fsprogs kmod-fs-ext4 losetup \
+ kmod-hwmon-tmp103 kmod-bluetooth
endef
TARGET_DEVICES += zyxel_nbg7815