aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-05-04 21:34:21 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 13:02:43 +0200
commit5bd7f04806d07a82e247220f2b825f4fcc43da9f (patch)
tree8d235ab8d4e32c304ca3187fd610b0f449af2698
parent1d3e71bd9710593cc0d7216b0ce9898b8e89aeef (diff)
downloadupstream-5bd7f04806d07a82e247220f2b825f4fcc43da9f.tar.gz
upstream-5bd7f04806d07a82e247220f2b825f4fcc43da9f.tar.bz2
upstream-5bd7f04806d07a82e247220f2b825f4fcc43da9f.zip
toolchain: glibc: increase min kernel version to 5.15
The purpose of this is to remove all of the compatibility code that is normally compiled into glibc for kernels < 5.15 from our build. Only Linux kernels >= 5.15 will be supported. Signed-off-by: Nick Hainke <vincent@systemli.org>
-rw-r--r--toolchain/glibc/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index ac396531c9..33afb2d60a 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -64,7 +64,7 @@ GLIBC_CONFIGURE:= \
$(if $(CONFIG_PKG_CC_STACKPROTECTOR_REGULAR),--enable-stack-protector=yes) \
$(if $(CONFIG_PKG_CC_STACKPROTECTOR_STRONG),--enable-stack-protector=strong) \
$(if $(CONFIG_PKG_RELRO_FULL),--enable-bind-now) \
- --enable-kernel=5.10.0
+ --enable-kernel=5.15.0
export libc_cv_ssp=no
export libc_cv_ssp_strong=no