aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-05-28 14:18:06 +0200
committerPetr Štetiar <ynezz@true.cz>2022-05-28 14:32:40 +0200
commit481339a0426698adaa0254b479807efde0428de9 (patch)
tree8c9d4fe942313d072903bd3b48b329a81f7aecc1
parentefff48529b5cdb4046b923bebee483c7c68755a7 (diff)
downloadupstream-481339a0426698adaa0254b479807efde0428de9.tar.gz
upstream-481339a0426698adaa0254b479807efde0428de9.tar.bz2
upstream-481339a0426698adaa0254b479807efde0428de9.zip
uboot-imx: fix wrong make flags overriding
Buidbots are currently choking on the following compile error: In file included from tools/aisimage.c:9: include/image.h:1133:12: fatal error: openssl/evp.h: No such file or directory # include <openssl/evp.h> ^~~~~~~~~~~~~~~ compilation terminated. This is caused by a complete overriding of make flags which are provided correctly in `UBOOT_MAKE_FLAGS` variable, but currently overriden instead of extended. This then leads to the usage of build host include dirs, which are not available. Fix it by extending `UBOOT_MAKE_FLAGS` variable in all device recipes. Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--package/boot/uboot-imx/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/boot/uboot-imx/Makefile b/package/boot/uboot-imx/Makefile
index 63f145798d..305d127557 100644
--- a/package/boot/uboot-imx/Makefile
+++ b/package/boot/uboot-imx/Makefile
@@ -23,7 +23,7 @@ endef
define U-Boot/apalis_imx6
NAME:=Toradex Apalis
UBOOT_IMAGE:=SPL u-boot.img u-boot-with-spl.imx
- UBOOT_MAKE_FLAGS:=SPL u-boot.img u-boot-with-spl.imx
+ UBOOT_MAKE_FLAGS+=SPL u-boot.img u-boot-with-spl.imx
BUILD_SUBTARGET:=cortexa9
BUILD_DEVICES:=toradex_apalis
endef
@@ -31,7 +31,7 @@ endef
define U-Boot/mx6cuboxi
NAME:=SolidRun Cubox-i boards
UBOOT_IMAGE:=SPL u-boot-dtb.img
- UBOOT_MAKE_FLAGS:=SPL u-boot-dtb.img
+ UBOOT_MAKE_FLAGS+=SPL u-boot-dtb.img
BUILD_SUBTARGET:=cortexa9
BUILD_DEVICES:=solidrun_cubox-i
endef