aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Norris <computersforpeace@gmail.com>2023-02-04 16:35:35 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-18 19:58:22 +0100
commit46ea81ba9918020cb4a9e81536f9b50c48ed9a5c (patch)
treebfa67e614ca4d61d6d3da3d92ecc1e3d37d465cd
parenta79abd813da1976ef3ff2093973b7dae7a90882c (diff)
downloadupstream-46ea81ba9918020cb4a9e81536f9b50c48ed9a5c.tar.gz
upstream-46ea81ba9918020cb4a9e81536f9b50c48ed9a5c.tar.bz2
upstream-46ea81ba9918020cb4a9e81536f9b50c48ed9a5c.zip
ipq40xx: chromium: Enable kmod-ramoops by default
Chromium devices (like Google WiFi) have ramoops memory reserved by the bootloader. Let's enable the ramoops kernel module by default, so we get better crash logging. Signed-off-by: Brian Norris <computersforpeace@gmail.com>
-rw-r--r--target/linux/ipq40xx/image/chromium.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/image/chromium.mk b/target/linux/ipq40xx/image/chromium.mk
index 2abd2df02a..f6ac69ecf1 100644
--- a/target/linux/ipq40xx/image/chromium.mk
+++ b/target/linux/ipq40xx/image/chromium.mk
@@ -30,7 +30,11 @@ define Device/google_wifi
KERNEL_NAME := zImage
IMAGES += factory.bin
IMAGE/factory.bin := cros-gpt | append-kernel-part | append-rootfs
+ # Note: Chromium/Depthcharge-based bootloaders insert a reserved-memory
+ # ramoops node into the Device Tree automatically, so we can use
+ # kmod-ramoops.
DEVICE_PACKAGES := partx-utils mkf2fs e2fsprogs \
- kmod-fs-ext4 kmod-fs-f2fs kmod-google-firmware
+ kmod-fs-ext4 kmod-fs-f2fs kmod-google-firmware \
+ kmod-ramoops
endef
TARGET_DEVICES += google_wifi