aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-02-08 18:04:25 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-19 19:44:39 +0100
commit1f1d1ff918748eacf32b1b6073094bb4f3e9e669 (patch)
treed2e4f2f3bfab12a3b085318402c8cef8263ef965
parentcd8366ad20e0596bf9a477453effb6dc9fe48b20 (diff)
downloadupstream-1f1d1ff918748eacf32b1b6073094bb4f3e9e669.tar.gz
upstream-1f1d1ff918748eacf32b1b6073094bb4f3e9e669.tar.bz2
upstream-1f1d1ff918748eacf32b1b6073094bb4f3e9e669.zip
toolchain/binutils: get rid of ARC leftovers
In [0] support for ARC specific binutils were added, which was later removed again [Fixes:]. Upstream binutils never had an extlib. [0] 8b5d644b "toolchain: add support of ARC architecture" Fixes: 8568dcd9 "toolchain: Remove binutils 2.29 for ARC targets" Signed-off-by: Andre Heider <a.heider@gmail.com>
-rw-r--r--toolchain/binutils/Makefile6
1 files changed, 0 insertions, 6 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index af670f5646..0b7558e358 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -102,12 +102,6 @@ define Host/Install
$(call FixupLibdir,$(TOOLCHAIN_DIR)/initial)
$(RM) $(TOOLCHAIN_DIR)/initial/lib/libiberty.a
$(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(HOST_BUILD_PREFIX)/bin/readelf
- # ARC gcc requires extlib.
- # If extlib is not available in "initial" folder
- # initial gcc will fail to build libc.
- if [ -d $(TOOLCHAIN_DIR)/extlib ]; then \
- $(CP) -r $(TOOLCHAIN_DIR)/extlib $(TOOLCHAIN_DIR)/initial/; \
- fi
endef
define Host/Clean