aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-02-15 16:58:41 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-02-15 23:28:57 +0100
commit061e863baef89776ede9478384458c434ccbf434 (patch)
tree33131407a46c205df47e0e276246ba47472f34d9
parentf06bd5bdb8e131a566d0f0068835296112f69915 (diff)
downloadupstream-061e863baef89776ede9478384458c434ccbf434.tar.gz
upstream-061e863baef89776ede9478384458c434ccbf434.tar.bz2
upstream-061e863baef89776ede9478384458c434ccbf434.zip
kernel: modules: package Aquantia PHY driver
Package the Aquantia AQR PHY driver as kmod. This enables using the Aquantia driver with hwmon support on targets where hwmon is not compiled-in. Currently, in case when AQR driver is compiled-in but hwmon core is not hwmon code in AQR driver will not get compiled because of macro IS_REACHABLE(CONFIG_HWMON) evaluating to false. Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--package/kernel/linux/modules/netdevices.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 518d83f9a2..248aaf06f7 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -340,6 +340,22 @@ endef
$(eval $(call KernelPackage,phy-smsc))
+define KernelPackage/phy-aquantia
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Aquantia Ethernet PHYs
+ DEPENDS:=+kmod-libphy +kmod-hwmon-core
+ KCONFIG:=CONFIG_AQUANTIA_PHY
+ FILES:=$(LINUX_DIR)/drivers/net/phy/aquantia.ko
+ AUTOLOAD:=$(call AutoLoad,18,aquantia,1)
+endef
+
+define KernelPackage/phy-aquantia/description
+ Kernel modules for Aquantia Ethernet PHYs
+endef
+
+$(eval $(call KernelPackage,phy-aquantia))
+
+
define KernelPackage/swconfig
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=switch configuration API