aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2022-12-30 15:55:56 +0800
committerChuanhong Guo <gch981213@gmail.com>2022-12-30 16:11:59 +0800
commitd29dbf052a1d34d7891b67177e1739db5d5af0bb (patch)
treeacdcba1e154ef6ccae748cb806d1060e8c62eb43
parent7272203022e38bc125ced9831ae1983fe3a34f45 (diff)
downloadupstream-d29dbf052a1d34d7891b67177e1739db5d5af0bb.tar.gz
upstream-d29dbf052a1d34d7891b67177e1739db5d5af0bb.tar.bz2
upstream-d29dbf052a1d34d7891b67177e1739db5d5af0bb.zip
mediatek: drop redmi-ax6000 variant with modified env
This variant uses xiaomi factory u-boot and modified u-boot-env & bootcmd. By modifying uboot-env, the xiaomi firmware recovery provided in the vendor u-boot doesn't work anymore. It's possible to put u-boot into a state where it refuese to take any serial input. If the u-boot is in this state, users can't restore their firmware without taking the flash off the board. We now have a -stock variant where the vendor u-boot is used in a way that xiaomi firmware recovery still works, and a -ubootmod variant where we get rid of all xiaomi components, have more usable space and no uart console lock. These two should cover all use cases and we don't need this variant anymore. Drop this redmi-ax6000 variant. Existing users of this variant should perform a u-boot mod or restore to the -stock layout. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
-rw-r--r--package/boot/uboot-envtools/files/mediatek_filogic1
-rw-r--r--target/linux/mediatek/dts/mt7986a-xiaomi-redmi-router-ax6000.dts42
-rw-r--r--target/linux/mediatek/filogic/base-files/etc/board.d/01_leds1
-rw-r--r--target/linux/mediatek/filogic/base-files/etc/board.d/02_network2
-rw-r--r--target/linux/mediatek/image/filogic.mk15
5 files changed, 0 insertions, 61 deletions
diff --git a/package/boot/uboot-envtools/files/mediatek_filogic b/package/boot/uboot-envtools/files/mediatek_filogic
index bdff66a17b..787fac8dd6 100644
--- a/package/boot/uboot-envtools/files/mediatek_filogic
+++ b/package/boot/uboot-envtools/files/mediatek_filogic
@@ -34,7 +34,6 @@ bananapi,bpi-r3)
;;
esac
;;
-xiaomi,redmi-router-ax6000|\
xiaomi,redmi-router-ax6000-stock)
ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x10000" "0x20000"
ubootenv_add_uci_sys_config "/dev/mtd2" "0x0" "0x10000" "0x20000"
diff --git a/target/linux/mediatek/dts/mt7986a-xiaomi-redmi-router-ax6000.dts b/target/linux/mediatek/dts/mt7986a-xiaomi-redmi-router-ax6000.dts
deleted file mode 100644
index 62407334cf..0000000000
--- a/target/linux/mediatek/dts/mt7986a-xiaomi-redmi-router-ax6000.dts
+++ /dev/null
@@ -1,42 +0,0 @@
-// SPDX-License-Identifier: (GPL-2.0 OR MIT)
-
-/dts-v1/;
-#include "mt7986a-xiaomi-redmi-router-ax6000.dtsi"
-
-/ {
- model = "Xiaomi Redmi Router AX6000";
- compatible = "xiaomi,redmi-router-ax6000", "mediatek,mt7986a";
-};
-
-&spi_nand_flash {
- mediatek,nmbm;
- mediatek,bmt-max-ratio = <1>;
- mediatek,bmt-max-reserved-blocks = <64>;
-};
-
-&partitions {
- partition@580000 {
- label = "crash";
- reg = <0x580000 0x40000>;
- read-only;
- };
-
- partition@5c0000 {
- label = "crash_log";
- reg = <0x5c0000 0x40000>;
- read-only;
- };
-
- /* ubi partition is the result of squashing
- * consecutive stock partitions:
- * - ubi
- * - ubi1
- * - overlay
- */
- partition@600000 {
- label = "ubi";
- reg = <0x600000 0x6e00000>;
- };
-
- /* last 12 MiB is reserved for NMBM bad block table */
-};
diff --git a/target/linux/mediatek/filogic/base-files/etc/board.d/01_leds b/target/linux/mediatek/filogic/base-files/etc/board.d/01_leds
index d85b12fb66..6b922de163 100644
--- a/target/linux/mediatek/filogic/base-files/etc/board.d/01_leds
+++ b/target/linux/mediatek/filogic/base-files/etc/board.d/01_leds
@@ -6,7 +6,6 @@ board=$(board_name)
board_config_update
case $board in
-xiaomi,redmi-router-ax6000|\
xiaomi,redmi-router-ax6000-stock|\
xiaomi,redmi-router-ax6000-ubootmod)
ucidef_set_led_netdev "wan" "wan" "rgb:network" "wan"
diff --git a/target/linux/mediatek/filogic/base-files/etc/board.d/02_network b/target/linux/mediatek/filogic/base-files/etc/board.d/02_network
index 608161f0ad..13f52587c3 100644
--- a/target/linux/mediatek/filogic/base-files/etc/board.d/02_network
+++ b/target/linux/mediatek/filogic/base-files/etc/board.d/02_network
@@ -16,7 +16,6 @@ mediatek_setup_interfaces()
ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4 sfp2" "eth1 wan"
ucidef_set_interface_macaddr "wan" "$(macaddr_add $(cat /sys/class/net/eth0/address) 1)"
;;
- xiaomi,redmi-router-ax6000|\
xiaomi,redmi-router-ax6000-stock|\
xiaomi,redmi-router-ax6000-ubootmod)
ucidef_set_interfaces_lan_wan "lan2 lan3 lan4" wan
@@ -35,7 +34,6 @@ mediatek_setup_macs()
local label_mac=""
case $board in
- xiaomi,redmi-router-ax6000|\
xiaomi,redmi-router-ax6000-stock|\
xiaomi,redmi-router-ax6000-ubootmod)
wan_mac=$(mtd_get_mac_ascii Bdata ethaddr_wan)
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index 4b16cff56e..5c223d04ff 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -125,21 +125,6 @@ define Device/mediatek_mt7986b-rfb
endef
TARGET_DEVICES += mediatek_mt7986b-rfb
-define Device/xiaomi_redmi-router-ax6000
- DEVICE_VENDOR := Xiaomi
- DEVICE_MODEL := Redmi Router AX6000
- DEVICE_DTS := mt7986a-xiaomi-redmi-router-ax6000
- DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-leds-ws2812b
- KERNEL_LOADADDR := 0x48000000
- UBINIZE_OPTS := -E 5
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- KERNEL_IN_UBI := 1
- IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
-endef
-TARGET_DEVICES += xiaomi_redmi-router-ax6000
-
define Device/xiaomi_redmi-router-ax6000-stock
DEVICE_VENDOR := Xiaomi
DEVICE_MODEL := Redmi Router AX6000 (stock layout)