aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSander Vanheule <sander@svanheule.net>2022-12-28 21:46:48 +0100
committerSander Vanheule <sander@svanheule.net>2022-12-28 22:44:10 +0100
commitab8a5f2ea0e15e69a1f5e14642034eb75b2317fd (patch)
tree23cf8411038619c28a6272cbd8707925ab7189de
parenta14170b6e9c8bab493c5e0e7689405a8a0675e8a (diff)
downloadupstream-ab8a5f2ea0e15e69a1f5e14642034eb75b2317fd.tar.gz
upstream-ab8a5f2ea0e15e69a1f5e14642034eb75b2317fd.tar.bz2
upstream-ab8a5f2ea0e15e69a1f5e14642034eb75b2317fd.zip
realtek: fix default image generation
While cleaning up the makefiles for the realtek target, the order of the default image generating commands was accidentally changed. This caused the image signature to end up somewhere in the middle, misaligning the rootfs. As a result, sysupgrade couldn't verify upgrade images anymore, and devices end up in a boot loop due to the unaligned (and not found) rootfs. Fixes: 94d8b4852b9f ("realtek: Cleanup Makefiles") Signed-off-by: Sander Vanheule <sander@svanheule.net>
-rw-r--r--target/linux/realtek/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index e4a3904aa8..66d7ee4895 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -102,11 +102,11 @@ define Device/Default
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := \
append-kernel | \
- append-metadata | \
+ pad-to 64k | \
append-rootfs | \
- check-size | \
pad-rootfs | \
- pad-to 64k
+ check-size | \
+ append-metadata
endef
include $(SUBTARGET).mk