aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Butler <spudz76@gmail.com>2022-12-06 16:39:27 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-28 21:19:17 +0100
commita7f3a51982be34270d9b10283f6d188bd54fc7a1 (patch)
treea95bcf5ca6806b269568c3f7080717e7be88655c
parentf83f5f8452edd3115aacf333b0038da89639a218 (diff)
downloadupstream-a7f3a51982be34270d9b10283f6d188bd54fc7a1.tar.gz
upstream-a7f3a51982be34270d9b10283f6d188bd54fc7a1.tar.bz2
upstream-a7f3a51982be34270d9b10283f6d188bd54fc7a1.zip
kernel: add kmod-lib-842
"842" is a compression scheme and this is the software implementation which is too slow to really use beyond a proof of concept. It can be selected in ZRAM, ZSWAP, or `fs/pstore`, and is here for completeness. In general you need a Power8 or better with 842-in-hardware for it to be fast, but other 842-accelerators are emerging. Signed-off-by: Tony Butler <spudz76@gmail.com>
-rw-r--r--package/kernel/linux/modules/lib.mk22
-rw-r--r--target/linux/generic/config-5.151
2 files changed, 23 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index d4d44ad8f0..299c5a8c35 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -170,6 +170,28 @@ endef
$(eval $(call KernelPackage,lib-lz4))
+define KernelPackage/lib-842
+ SUBMENU:=$(LIB_MENU)
+ TITLE:=842 support
+ DEPENDS:=+kmod-crypto-acompress +kmod-crypto-crc32
+ KCONFIG:= \
+ CONFIG_CRYPTO_842 \
+ CONFIG_842_COMPRESS \
+ CONFIG_842_DECOMPRESS
+ FILES:= \
+ $(LINUX_DIR)/crypto/842.ko \
+ $(LINUX_DIR)/lib/842/842_compress.ko \
+ $(LINUX_DIR)/lib/842/842_decompress.ko
+ AUTOLOAD:=$(call AutoProbe,842 842_compress 842_decompress)
+endef
+
+define KernelPackage/lib-842/description
+ Kernel module for 842 compression/decompression support
+endef
+
+$(eval $(call KernelPackage,lib-842))
+
+
define KernelPackage/lib-raid6
SUBMENU:=$(LIB_MENU)
TITLE:=RAID6 algorithm support
diff --git a/target/linux/generic/config-5.15 b/target/linux/generic/config-5.15
index 878a60e66b..bd27f74d73 100644
--- a/target/linux/generic/config-5.15
+++ b/target/linux/generic/config-5.15
@@ -7562,6 +7562,7 @@ CONFIG_ZONE_DMA=y
# CONFIG_ZPA2326 is not set
# CONFIG_ZPOOL is not set
# CONFIG_ZRAM is not set
+# CONFIG_ZRAM_DEF_COMP_842 is not set
# CONFIG_ZRAM_DEF_COMP_LZ4 is not set
# CONFIG_ZRAM_DEF_COMP_LZ4HC is not set
# CONFIG_ZRAM_DEF_COMP_LZO is not set