aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2022-12-28 22:57:49 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2022-12-29 14:15:55 +0100
commit9d8eff6799469e2ed8a5d2e4decd194902c1ec1b (patch)
tree90f63b2ccff2123614d83e94b731960a873be33e
parent1613e3340b829ea9aa6da954bf0ff98214b71751 (diff)
downloadupstream-9d8eff6799469e2ed8a5d2e4decd194902c1ec1b.tar.gz
upstream-9d8eff6799469e2ed8a5d2e4decd194902c1ec1b.tar.bz2
upstream-9d8eff6799469e2ed8a5d2e4decd194902c1ec1b.zip
linux-firmware: disable stripping
It has been brought to my attention that recently added WCN6855 firmware is broken as it is getting stripped during building due to being 2 ELF binaries. I am sure WCN6750 and any other ELF binaries are having the same issue, so since stripping firmware binaries is clearly unwanted disable it. Fixes: b4d3694f81f4 ("linux-firmware: package ath11k consumer cards firmware") Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--package/firmware/linux-firmware/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/firmware/linux-firmware/Makefile b/package/firmware/linux-firmware/Makefile
index 70c63f172e..7ffd8baf88 100644
--- a/package/firmware/linux-firmware/Makefile
+++ b/package/firmware/linux-firmware/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=linux-firmware
PKG_VERSION:=20221214
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL:=@KERNEL/linux/kernel/firmware
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -21,6 +21,9 @@ SCAN_DEPS = *.mk
include $(INCLUDE_DIR)/package.mk
+RSTRIP:=:
+STRIP:=:
+
define Package/firmware-default
SECTION:=firmware
CATEGORY:=Firmware