aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2022-12-05 19:38:45 -0800
committerTony Ambardar <itugrok@yahoo.com>2022-12-31 05:02:38 -0800
commit4b367e2b606583bb1316a54d952935893bc53c6c (patch)
tree749ff3e49fd7612fe009c9ed2d9f96f81e6e5c73
parent2a9f3b7717d081a9d6cb34d7ad04e14b4e50d69e (diff)
downloadupstream-4b367e2b606583bb1316a54d952935893bc53c6c.tar.gz
upstream-4b367e2b606583bb1316a54d952935893bc53c6c.tar.bz2
upstream-4b367e2b606583bb1316a54d952935893bc53c6c.zip
ipq40xx: migrate Linksys WHW01 to DSA and re-enable
Convert Linksys WHW01 network configuration to DSA and re-enable builds. Reviewed-by: Robert Marko <robimarko@gmail.com> Tested-by: Wyatt Martin <wawowl@gmail.com> Signed-off-by: Wyatt Martin <wawowl@gmail.com> Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
-rw-r--r--target/linux/ipq40xx/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-whw01.dts18
-rw-r--r--target/linux/ipq40xx/image/generic.mk3
3 files changed, 22 insertions, 2 deletions
diff --git a/target/linux/ipq40xx/base-files/etc/board.d/02_network b/target/linux/ipq40xx/base-files/etc/board.d/02_network
index bceb434bff..7a4cac868c 100644
--- a/target/linux/ipq40xx/base-files/etc/board.d/02_network
+++ b/target/linux/ipq40xx/base-files/etc/board.d/02_network
@@ -59,6 +59,9 @@ ipq40xx_setup_interfaces()
compex,wpj428)
ucidef_set_interface_lan "lan1 lan2"
;;
+ linksys,whw01)
+ ucidef_set_interface_lan "eth1 eth2"
+ ;;
glinet,gl-a1300|\
glinet,gl-b1300|\
mobipromo,cm520-79f)
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-whw01.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-whw01.dts
index 09349219ed..5859548254 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-whw01.dts
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-whw01.dts
@@ -316,3 +316,21 @@
nvmem-cell-names = "pre-calibration";
nvmem-cells = <&precal_art_5000>;
};
+
+&gmac {
+ status = "okay";
+};
+
+&switch {
+ status = "okay";
+};
+
+&swport4 {
+ status = "okay";
+ label = "eth1";
+};
+
+&swport5 {
+ status = "okay";
+ label = "eth2";
+};
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index a2807c6c9c..f92e11c797 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -734,8 +734,7 @@ define Device/linksys_whw01
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=WHW01
DEVICE_PACKAGES := uboot-envtools kmod-leds-pca963x
endef
-# Missing DSA Setup
-#TARGET_DEVICES += linksys_whw01
+TARGET_DEVICES += linksys_whw01
define Device/luma_wrtq-329acn
$(call Device/FitImage)