aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-07 12:48:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-07 12:48:23 +0000
commit600d745974c714f5719a1dba626740249f4c722a (patch)
tree69c6d38b00a08abb605bea8914e587f45263afd4
parentf0fa4c289a579b962af0bec84bad324356288673 (diff)
downloadupstream-600d745974c714f5719a1dba626740249f4c722a.tar.gz
upstream-600d745974c714f5719a1dba626740249f4c722a.tar.bz2
upstream-600d745974c714f5719a1dba626740249f4c722a.zip
fix gdb installation (patch from #809)
SVN-Revision: 4945
-rw-r--r--openwrt/toolchain/gdb/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/openwrt/toolchain/gdb/Makefile b/openwrt/toolchain/gdb/Makefile
index 63661ca2dc..34dca715a7 100644
--- a/openwrt/toolchain/gdb/Makefile
+++ b/openwrt/toolchain/gdb/Makefile
@@ -40,9 +40,16 @@ define Build/Compile
endef
define Build/Install
- install -c $(PKG_BUILD_DIR)/gdb/gdb $(TARGET_CROSS)gdb
- cd $(STAGING_DIR)/bin && \
- ln -fs $(TARGET_CROSS)gdb $(GNU_TARGET_NAME)-gdb
+ (cd $(STAGING_DIR)/bin; \
+ install -c $(PKG_BUILD_DIR)/gdb/gdb $(TARGET_CROSS)gdb; \
+ ln -fs $(TARGET_CROSS)gdb $(GNU_TARGET_NAME)-gdb; \
+ );
+endef
+
+define Build/Clean
+ rm -rf $(PKG_BUILD_DIR)
+ rm -f $(STAGING_DIR)/bin/$(TARGET_CROSS)gdb
+ rm -f $(STAGING_DIR)/bin/$(GNU_TARGET_NAME)-gdb
endef
$(eval $(call HostBuild))