aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2022-09-06 15:32:34 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-09-07 21:21:38 +0200
commit47306d47ef1873f11cbfb2cd24f4e12a83a31301 (patch)
tree10aae80e17edb89837396ae0279ec3abbfd37dc3
parent80baffd2aa91a1e95f818e7e9f7d668d3b64ed42 (diff)
downloadupstream-47306d47ef1873f11cbfb2cd24f4e12a83a31301.tar.gz
upstream-47306d47ef1873f11cbfb2cd24f4e12a83a31301.tar.bz2
upstream-47306d47ef1873f11cbfb2cd24f4e12a83a31301.zip
ipq-wifi: add Pakedge WR-1 support
Calibration variants: Pakedge-WR-1 ETSI, FCC and IC-2.4GHz Pakedge-WR-1-ACMA ACMA Pakedge-WR-1-IC IC-5GHz Pakedge-WR-1-SRRC SRRC Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
-rw-r--r--package/firmware/ipq-wifi/Makefile2
-rw-r--r--package/firmware/ipq-wifi/board-pakedge_wr-1.qca4019bin0 -> 85076 bytes
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts4
-rw-r--r--target/linux/ipq40xx/image/generic.mk1
4 files changed, 7 insertions, 0 deletions
diff --git a/package/firmware/ipq-wifi/Makefile b/package/firmware/ipq-wifi/Makefile
index 44d6e2a086..7b683ef0a2 100644
--- a/package/firmware/ipq-wifi/Makefile
+++ b/package/firmware/ipq-wifi/Makefile
@@ -34,6 +34,7 @@ ALLWIFIBOARDS:= \
glinet_gl-s1300 \
linksys_ea8300 \
p2w_r619ac \
+ pakedge_wr-1 \
qxwlan_e2600ac-c1 \
qxwlan_e2600ac-c2 \
teltonika_rutx
@@ -106,6 +107,7 @@ $(eval $(call generate-ipq-wifi-package,glinet_gl-ap1300,GL.iNet GL-AP1300))
$(eval $(call generate-ipq-wifi-package,glinet_gl-s1300,GL.iNet GL-S1300))
$(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
$(eval $(call generate-ipq-wifi-package,p2w_r619ac,P&W R619AC))
+$(eval $(call generate-ipq-wifi-package,pakedge_wr-1,Pakedge WR-1))
$(eval $(call generate-ipq-wifi-package,qxwlan_e2600ac-c1,Qxwlan E2600AC C1))
$(eval $(call generate-ipq-wifi-package,qxwlan_e2600ac-c2,Qxwlan E2600AC C2))
$(eval $(call generate-ipq-wifi-package,teltonika_rutx,Teltonika RUTX))
diff --git a/package/firmware/ipq-wifi/board-pakedge_wr-1.qca4019 b/package/firmware/ipq-wifi/board-pakedge_wr-1.qca4019
new file mode 100644
index 0000000000..967a452580
--- /dev/null
+++ b/package/firmware/ipq-wifi/board-pakedge_wr-1.qca4019
Binary files differ
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
index 26a8b013aa..be2f619b39 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
@@ -257,8 +257,12 @@
&wifi0 {
status = "okay";
+
+ qcom,ath10k-calibration-variant = "Pakedge-WR-1";
};
&wifi1 {
status = "okay";
+
+ qcom,ath10k-calibration-variant = "Pakedge-WR-1";
};
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 5652bf9414..98a40349b2 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -899,6 +899,7 @@ define Device/pakedge_wr-1
DEVICE_VENDOR := Pakedge
DEVICE_MODEL := WR-1
DEVICE_DTS_CONFIG := config@ap.dk01.1-c1
+ DEVICE_PACKAGES := ipq-wifi-pakedge_wr-1
SOC := qcom-ipq4018
BLOCKSIZE := 64k
IMAGE_SIZE := 31232k