aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2022-02-28 10:20:53 +0100
committerPaul Spooren <mail@aparcar.org>2022-02-28 23:52:13 +0100
commita9478490d86e16f130f12fe5394ee484dcf13822 (patch)
tree8d60cca7332077cd6841c7a5b5f8332ed7c7f4fd
parentaee3594ffcb72ae3e18c3719012d52519ee2d160 (diff)
downloadupstream-a9478490d86e16f130f12fe5394ee484dcf13822.tar.gz
upstream-a9478490d86e16f130f12fe5394ee484dcf13822.tar.bz2
upstream-a9478490d86e16f130f12fe5394ee484dcf13822.zip
image-commands.mk: Use ERROR_MESSAGE for imagesize fails
If a image is bigger than the device can handle, an error message is printed. This is usually silenced and silently ignored, making it harder to debug. While it's possible to run the build in verbose mode (via `make V=s`) and grep for *is too big*, it's more intuitive to print the error message directly. For that use the newly unlocked `$(call ERROR_MESSAGE,...)` definition which now also print in non-verbose mode. Fixes: FS#50 (aka #7604) Signed-off-by: Paul Spooren <mail@aparcar.org>
-rw-r--r--include/image-commands.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 485d870f05..939f5ef2db 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -191,7 +191,7 @@ define Build/check-size
@imagesize="$$(stat -c%s $@)"; \
limitsize="$$(($(subst k,* 1024,$(subst m, * 1024k,$(if $(1),$(1),$(IMAGE_SIZE))))))"; \
[ $$limitsize -ge $$imagesize ] || { \
- echo "WARNING: Image file $@ is too big: $$imagesize > $$limitsize" >&2; \
+ $(call ERROR_MESSAGE, WARNING: Image file $@ is too big: $$imagesize > $$limitsize); \
rm -f $@; \
}
endef