aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2022-10-26 23:05:31 +0200
committerDoug Freed <dwfreed@mtu.edu>2023-02-09 08:37:22 +0000
commit98b8507e83c69d5e66e442eca95fc076114a736a (patch)
tree599c7a72a6a0156781cdc9b491860f8fd4de0d5b
parent7370479224dde700537a73a81706bde6db820d8a (diff)
downloadupstream-98b8507e83c69d5e66e442eca95fc076114a736a.tar.gz
upstream-98b8507e83c69d5e66e442eca95fc076114a736a.tar.bz2
upstream-98b8507e83c69d5e66e442eca95fc076114a736a.zip
bpf: check llvm version only when used
unetd always includes $(INCLUDE_DIR)/bpf.mk. This file always checks if the LLVM version is supported in CLANG_VER_VALID. unetd only needs bpf when UNETD_VXLAN_SUPPORT is set. It fails when UNETD_VXLAN_SUPPORT is not set and llvm is not installed. Fix it by only checking the LLVM version when a LLVM toolchain is available. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit c58177b5dcb3461efef0adefe570dd8a8d966ec4)
-rw-r--r--include/bpf.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/bpf.mk b/include/bpf.mk
index 7d0cfbd76d..e43fcad50c 100644
--- a/include/bpf.mk
+++ b/include/bpf.mk
@@ -63,6 +63,7 @@ BPF_CFLAGS := \
-Wno-unused-label \
-O2 -emit-llvm -Xclang -disable-llvm-passes
+ifneq ($(CONFIG_HAS_BPF_TOOLCHAIN),)
ifeq ($(DUMP),)
CLANG_VER:=$(shell $(CLANG) -dM -E - < /dev/null | grep __clang_major__ | cut -d' ' -f3)
CLANG_VER_VALID:=$(shell [ "$(CLANG_VER)" -ge "$(CLANG_MIN_VER)" ] && echo 1 )
@@ -70,6 +71,7 @@ ifeq ($(DUMP),)
$(error ERROR: LLVM/clang version too old. Minimum required: $(CLANG_MIN_VER), found: $(CLANG_VER))
endif
endif
+endif
define CompileBPF
$(CLANG) -g -target $(BPF_ARCH)-linux-gnu $(BPF_CFLAGS) $(2) \