diff options
author | Florian Fainelli <florian@openwrt.org> | 2010-07-31 22:32:21 +0000 |
---|---|---|
committer | Florian Fainelli <florian@openwrt.org> | 2010-07-31 22:32:21 +0000 |
commit | 7fc192e9a5d517f48561243d24a5e0a88cdd0805 (patch) | |
tree | 2cc03c881207bd49048e91d6c87f4dab5f7c52bb | |
parent | 5b365822f3249c4b7f0304ee5c9f526e1ba1c695 (diff) | |
download | upstream-7fc192e9a5d517f48561243d24a5e0a88cdd0805.tar.gz upstream-7fc192e9a5d517f48561243d24a5e0a88cdd0805.tar.bz2 upstream-7fc192e9a5d517f48561243d24a5e0a88cdd0805.zip |
fix for GREP_OPTIONS
When using GREP_OPTIONS to supply default options to grep, the buildsystem might get broken (For example adding --color=always breaks it)
This patch will empty the GREP_OPTIONS to prevent the described (and any other) problems related to GREP_OPTIONS
Signed-off-by: Maarten Bezemer <m.m.bezemer@utwente.nl>
SVN-Revision: 22443
-rw-r--r-- | Makefile | 2 | ||||
-rw-r--r-- | rules.mk | 3 |
2 files changed, 5 insertions, 0 deletions
@@ -24,6 +24,8 @@ ifneq ($(OPENWRT_BUILD),1) override OPENWRT_BUILD=1 export OPENWRT_BUILD + GREP_OPTIONS= + export GREP_OPTIONS include $(TOPDIR)/include/debug.mk include $(TOPDIR)/include/depends.mk include $(TOPDIR)/include/toplevel.mk @@ -18,6 +18,9 @@ TMP_DIR:=$(TOPDIR)/tmp export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' -- +GREP_OPTIONS= +export GREP_OPTIONS + qstrip=$(strip $(subst ",,$(1))) #")) |