aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2023-03-12 16:56:41 +0100
committerPaul Spooren <mail@aparcar.org>2023-04-09 14:27:46 +0200
commit38ccc4768719c4a5f67e04383a299e17b6b825cb (patch)
treeefa98fd7a38d5d627fd505c68dcfa7cea51d6ec4
parentdeafcf91627921b2044b2e96de1067cdbaf23d31 (diff)
downloadupstream-38ccc4768719c4a5f67e04383a299e17b6b825cb.tar.gz
upstream-38ccc4768719c4a5f67e04383a299e17b6b825cb.tar.bz2
upstream-38ccc4768719c4a5f67e04383a299e17b6b825cb.zip
imagebuilder: allow to specific ROOTFS_PARTSIZE
Setting this options modifies the rootfs size of created images. When installing a large number of packages it may become necessary to increase the size to have enough storage. This option is only useful for supported devices, i.e. with an attached SD Card or installed on a hard drive. Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 7b7edd25a571568438c886529d3443054e02f55f)
-rw-r--r--target/imagebuilder/files/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 3329fe70aa..44b4a380c3 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -48,6 +48,7 @@ Building images:
make image EXTRA_IMAGE_NAME="<string>" # Add this to the output image filename (sanitized)
make image DISABLED_SERVICES="<svc1> [<svc2> [<svc3> ..]]" # Which services in /etc/init.d/ should be disabled
make image ADD_LOCAL_KEY=1 # store locally generated signing key in built images
+ make image ROOTFS_PARTSIZE="<size>" # override the default rootfs partition size in MegaBytes
Print manifest:
List "all" packages which get installed into the image.
@@ -245,7 +246,8 @@ image:
$(if $(FILES),USER_FILES="$(FILES)") \
$(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)") \
$(if $(BIN_DIR),BIN_DIR="$(BIN_DIR)") \
- $(if $(DISABLED_SERVICES),DISABLED_SERVICES="$(DISABLED_SERVICES)"))
+ $(if $(DISABLED_SERVICES),DISABLED_SERVICES="$(DISABLED_SERVICES)") \
+ $(if $(ROOTFS_PARTSIZE),CONFIG_TARGET_ROOTFS_PARTSIZE="$(ROOTFS_PARTSIZE)"))
manifest: FORCE
$(MAKE) -s _check_profile