aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2022-02-25 12:30:08 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-01 21:17:30 +0100
commitba6a48366f4ae4b7b47a11f95141554c52a2a5db (patch)
tree7426b4af6b4a69f07efdf312232adf1d05d7b3e9
parent495c4f4e197166a6fa997d4620ca6c241e3abd45 (diff)
downloadupstream-ba6a48366f4ae4b7b47a11f95141554c52a2a5db.tar.gz
upstream-ba6a48366f4ae4b7b47a11f95141554c52a2a5db.tar.bz2
upstream-ba6a48366f4ae4b7b47a11f95141554c52a2a5db.zip
ipset: update to 7.15
Update to the latest upstream version. In this version there is a new tool with which you can convert ipsets into nftables sets. Since we are now using nftables as default firewall, this could be a useful tool for porting ipsets to nftables sets. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
-rw-r--r--package/network/utils/ipset/Makefile5
-rw-r--r--package/network/utils/ipset/patches/0001-lib-ipset-fix-printf-warning.patch11
2 files changed, 14 insertions, 2 deletions
diff --git a/package/network/utils/ipset/Makefile b/package/network/utils/ipset/Makefile
index bc4945e0f6..7b8d035198 100644
--- a/package/network/utils/ipset/Makefile
+++ b/package/network/utils/ipset/Makefile
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ipset
-PKG_VERSION:=7.6
+PKG_VERSION:=7.15
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ipset.netfilter.org
-PKG_HASH:=0e7d44caa9c153d96a9b5f12644fbe35a632537a5a7f653792b72e53d9d5c2db
+PKG_HASH:=0a5545aaadb640142c1f888d366a78ddf8724799967fa20686a70053bd621751
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=GPL-2.0
@@ -62,6 +62,7 @@ endef
define Package/ipset/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/ipset $(1)/usr/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ipset-translate $(1)/usr/sbin/
endef
define Package/libipset/install
diff --git a/package/network/utils/ipset/patches/0001-lib-ipset-fix-printf-warning.patch b/package/network/utils/ipset/patches/0001-lib-ipset-fix-printf-warning.patch
new file mode 100644
index 0000000000..90dfacab8f
--- /dev/null
+++ b/package/network/utils/ipset/patches/0001-lib-ipset-fix-printf-warning.patch
@@ -0,0 +1,11 @@
+--- a/lib/ipset.c
++++ b/lib/ipset.c
+@@ -1847,7 +1847,7 @@ static int ipset_xlate(struct ipset *ips
+ return -1;
+ case IPSET_CMD_LIST:
+ if (!set) {
+- printf("list sets %s\n",
++ printf("list sets %s %s\n",
+ ipset_xlate_family(family), table);
+ } else {
+ printf("list set %s %s %s\n",