aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2021-09-30 14:21:41 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-09-30 22:29:33 +0100
commitb4cee3b63ff042b394f9bb3e0d8c39b7f6707dfa (patch)
tree5ba5ce1681ccb721347c0c6a1aa7246aecd5e63e
parent2bf320a5e51a3dec733ab75b4d8085655c7f5ba6 (diff)
downloadupstream-b4cee3b63ff042b394f9bb3e0d8c39b7f6707dfa.tar.gz
upstream-b4cee3b63ff042b394f9bb3e0d8c39b7f6707dfa.tar.bz2
upstream-b4cee3b63ff042b394f9bb3e0d8c39b7f6707dfa.zip
kernel: bump 5.10 to 5.10.70
Deleted (upstreamed): bcm53xx/patches-5.10/181-Revert-USB-bcma-Add-a-check-for-devm_gpiod_get.patch Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0138-usb-add-plumbing-for-updating-interrupt-endpoint-int.patch4
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0139-xhci-implement-xhci_fixup_endpoint-for-interval-adju.patch4
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0735-xhci-guard-accesses-to-ep_state-in-xhci_endpoint_res.patch4
-rw-r--r--target/linux/bcm53xx/patches-5.10/181-Revert-USB-bcma-Add-a-check-for-devm_gpiod_get.patch41
-rw-r--r--target/linux/generic/pending-5.10/100-compiler.h-only-include-asm-rwonce.h-for-kernel-code.patch4
-rw-r--r--target/linux/generic/pending-5.10/811-pci_disable_usb_common_quirks.patch2
-rw-r--r--target/linux/realtek/patches-5.10/704-drivers-net-phy-eee-support-for-rtl838x.patch4
8 files changed, 13 insertions, 54 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 2bb55cb49a..216b2f6369 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
endif
LINUX_VERSION-5.4 = .145
-LINUX_VERSION-5.10 = .69
+LINUX_VERSION-5.10 = .70
LINUX_KERNEL_HASH-5.4.145 = 5cf7782ec2e91417edf0d5e6555da6d556962c8985e33ba9e7dadba5cbdc68f9
-LINUX_KERNEL_HASH-5.10.69 = 232f9ec53bccca768868831b7cc286f7d8bbbac9f481bbac1495700231a20cca
+LINUX_KERNEL_HASH-5.10.70 = 75736c33711d7f298889ee4981b18774882045323e5c46af9ad3b022082db232
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/bcm27xx/patches-5.10/950-0138-usb-add-plumbing-for-updating-interrupt-endpoint-int.patch b/target/linux/bcm27xx/patches-5.10/950-0138-usb-add-plumbing-for-updating-interrupt-endpoint-int.patch
index a168528edf..43da930871 100644
--- a/target/linux/bcm27xx/patches-5.10/950-0138-usb-add-plumbing-for-updating-interrupt-endpoint-int.patch
+++ b/target/linux/bcm27xx/patches-5.10/950-0138-usb-add-plumbing-for-updating-interrupt-endpoint-int.patch
@@ -81,7 +81,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
extern int usb_driver_set_configuration(struct usb_device *udev, int config);
--- a/include/linux/usb/hcd.h
+++ b/include/linux/usb/hcd.h
-@@ -382,6 +382,11 @@ struct hc_driver {
+@@ -384,6 +384,11 @@ struct hc_driver {
* or bandwidth constraints.
*/
void (*reset_bandwidth)(struct usb_hcd *, struct usb_device *);
@@ -93,7 +93,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
/* Returns the hardware-chosen device address */
int (*address_device)(struct usb_hcd *, struct usb_device *udev);
/* prepares the hardware to send commands to the device */
-@@ -443,6 +448,8 @@ extern void usb_hcd_unmap_urb_setup_for_
+@@ -445,6 +450,8 @@ extern void usb_hcd_unmap_urb_setup_for_
extern void usb_hcd_unmap_urb_for_dma(struct usb_hcd *, struct urb *);
extern void usb_hcd_flush_endpoint(struct usb_device *udev,
struct usb_host_endpoint *ep);
diff --git a/target/linux/bcm27xx/patches-5.10/950-0139-xhci-implement-xhci_fixup_endpoint-for-interval-adju.patch b/target/linux/bcm27xx/patches-5.10/950-0139-xhci-implement-xhci_fixup_endpoint-for-interval-adju.patch
index 406bb04d46..391af473d1 100644
--- a/target/linux/bcm27xx/patches-5.10/950-0139-xhci-implement-xhci_fixup_endpoint-for-interval-adju.patch
+++ b/target/linux/bcm27xx/patches-5.10/950-0139-xhci-implement-xhci_fixup_endpoint-for-interval-adju.patch
@@ -15,7 +15,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
--- a/drivers/usb/host/xhci.c
+++ b/drivers/usb/host/xhci.c
-@@ -1467,6 +1467,103 @@ command_cleanup:
+@@ -1468,6 +1468,103 @@ command_cleanup:
}
/*
@@ -119,7 +119,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
* non-error returns are a promise to giveback() the urb later
* we drop ownership so next owner (or urb unlink) can get it
*/
-@@ -5361,6 +5458,7 @@ static const struct hc_driver xhci_hc_dr
+@@ -5362,6 +5459,7 @@ static const struct hc_driver xhci_hc_dr
.endpoint_reset = xhci_endpoint_reset,
.check_bandwidth = xhci_check_bandwidth,
.reset_bandwidth = xhci_reset_bandwidth,
diff --git a/target/linux/bcm27xx/patches-5.10/950-0735-xhci-guard-accesses-to-ep_state-in-xhci_endpoint_res.patch b/target/linux/bcm27xx/patches-5.10/950-0735-xhci-guard-accesses-to-ep_state-in-xhci_endpoint_res.patch
index d9a51605d4..9cf5aa2e99 100644
--- a/target/linux/bcm27xx/patches-5.10/950-0735-xhci-guard-accesses-to-ep_state-in-xhci_endpoint_res.patch
+++ b/target/linux/bcm27xx/patches-5.10/950-0735-xhci-guard-accesses-to-ep_state-in-xhci_endpoint_res.patch
@@ -16,7 +16,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
--- a/drivers/usb/host/xhci.c
+++ b/drivers/usb/host/xhci.c
-@@ -3269,10 +3269,13 @@ static void xhci_endpoint_reset(struct u
+@@ -3270,10 +3270,13 @@ static void xhci_endpoint_reset(struct u
return;
/* Bail out if toggle is already being cleared by a endpoint reset */
@@ -30,7 +30,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
/* Only interrupt and bulk ep's use data toggle, USB2 spec 5.5.4-> */
if (usb_endpoint_xfer_control(&host_ep->desc) ||
usb_endpoint_xfer_isoc(&host_ep->desc))
-@@ -3358,8 +3361,10 @@ static void xhci_endpoint_reset(struct u
+@@ -3359,8 +3362,10 @@ static void xhci_endpoint_reset(struct u
xhci_free_command(xhci, cfg_cmd);
cleanup:
xhci_free_command(xhci, stop_cmd);
diff --git a/target/linux/bcm53xx/patches-5.10/181-Revert-USB-bcma-Add-a-check-for-devm_gpiod_get.patch b/target/linux/bcm53xx/patches-5.10/181-Revert-USB-bcma-Add-a-check-for-devm_gpiod_get.patch
deleted file mode 100644
index 9e424760ce..0000000000
--- a/target/linux/bcm53xx/patches-5.10/181-Revert-USB-bcma-Add-a-check-for-devm_gpiod_get.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
-Date: Tue, 31 Aug 2021 08:40:49 +0200
-Subject: [PATCH fix] Revert "USB: bcma: Add a check for devm_gpiod_get"
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-This reverts commit f3de5d857bb2362b00e2a8d4bc886cd49dcb66db.
-
-That commit broke USB on all routers that have USB always powered on and
-don't require toggling any GPIO. It's a majority of devices actually.
-
-The original code worked and seemed safe: vcc GPIO is optional and
-bcma_hci_platform_power_gpio() takes care of checking the pointer before
-using it.
-
-This revert fixes:
-[ 10.801127] bcma_hcd: probe of bcma0:11 failed with error -2
-
-Cc: Chuhong Yuan <hslester96@gmail.com>
-Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
----
- drivers/usb/host/bcma-hcd.c | 5 +----
- 1 file changed, 1 insertion(+), 4 deletions(-)
-
---- a/drivers/usb/host/bcma-hcd.c
-+++ b/drivers/usb/host/bcma-hcd.c
-@@ -406,12 +406,9 @@ static int bcma_hcd_probe(struct bcma_de
- return -ENOMEM;
- usb_dev->core = core;
-
-- if (core->dev.of_node) {
-+ if (core->dev.of_node)
- usb_dev->gpio_desc = devm_gpiod_get(&core->dev, "vcc",
- GPIOD_OUT_HIGH);
-- if (IS_ERR(usb_dev->gpio_desc))
-- return PTR_ERR(usb_dev->gpio_desc);
-- }
-
- switch (core->id.id) {
- case BCMA_CORE_USB20_HOST:
diff --git a/target/linux/generic/pending-5.10/100-compiler.h-only-include-asm-rwonce.h-for-kernel-code.patch b/target/linux/generic/pending-5.10/100-compiler.h-only-include-asm-rwonce.h-for-kernel-code.patch
index 39b98eac1b..282c8196e5 100644
--- a/target/linux/generic/pending-5.10/100-compiler.h-only-include-asm-rwonce.h-for-kernel-code.patch
+++ b/target/linux/generic/pending-5.10/100-compiler.h-only-include-asm-rwonce.h-for-kernel-code.patch
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/include/linux/compiler.h
+++ b/include/linux/compiler.h
-@@ -211,6 +211,8 @@ void ftrace_likely_update(struct ftrace_
+@@ -213,6 +213,8 @@ void ftrace_likely_update(struct ftrace_
__v; \
})
@@ -20,7 +20,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#endif /* __KERNEL__ */
/*
-@@ -243,6 +245,4 @@ static inline void *offset_to_ptr(const
+@@ -245,6 +247,4 @@ static inline void *offset_to_ptr(const
*/
#define prevent_tail_call_optimization() mb()
diff --git a/target/linux/generic/pending-5.10/811-pci_disable_usb_common_quirks.patch b/target/linux/generic/pending-5.10/811-pci_disable_usb_common_quirks.patch
index 42a8397839..cf52fa36ca 100644
--- a/target/linux/generic/pending-5.10/811-pci_disable_usb_common_quirks.patch
+++ b/target/linux/generic/pending-5.10/811-pci_disable_usb_common_quirks.patch
@@ -98,7 +98,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#endif /* __LINUX_USB_PCI_QUIRKS_H */
--- a/include/linux/usb/hcd.h
+++ b/include/linux/usb/hcd.h
-@@ -484,7 +484,14 @@ extern int usb_hcd_pci_probe(struct pci_
+@@ -486,7 +486,14 @@ extern int usb_hcd_pci_probe(struct pci_
extern void usb_hcd_pci_remove(struct pci_dev *dev);
extern void usb_hcd_pci_shutdown(struct pci_dev *dev);
diff --git a/target/linux/realtek/patches-5.10/704-drivers-net-phy-eee-support-for-rtl838x.patch b/target/linux/realtek/patches-5.10/704-drivers-net-phy-eee-support-for-rtl838x.patch
index cca724293d..4fc31c4f4f 100644
--- a/target/linux/realtek/patches-5.10/704-drivers-net-phy-eee-support-for-rtl838x.patch
+++ b/target/linux/realtek/patches-5.10/704-drivers-net-phy-eee-support-for-rtl838x.patch
@@ -12,7 +12,7 @@
return phy_ethtool_ksettings_set(pl->phydev, kset);
}
-@@ -1700,8 +1705,11 @@ int phylink_ethtool_get_eee(struct phyli
+@@ -1726,8 +1731,11 @@ int phylink_ethtool_get_eee(struct phyli
ASSERT_RTNL();
@@ -25,7 +25,7 @@
return ret;
}
-@@ -1718,8 +1726,11 @@ int phylink_ethtool_set_eee(struct phyli
+@@ -1744,8 +1752,11 @@ int phylink_ethtool_set_eee(struct phyli
ASSERT_RTNL();