aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-12-01 10:36:01 +0100
committerPetr Štetiar <ynezz@true.cz>2022-12-05 15:16:19 +0100
commita0bae2fef8bdd4f76767e1b29deb1adf279403e9 (patch)
tree201dbf1ba0b169ea44274807f324c88dcc0c33a4
parent309a6f22baeff66213822f3cdb92c4b5fbfbe59c (diff)
downloadupstream-a0bae2fef8bdd4f76767e1b29deb1adf279403e9.tar.gz
upstream-a0bae2fef8bdd4f76767e1b29deb1adf279403e9.tar.bz2
upstream-a0bae2fef8bdd4f76767e1b29deb1adf279403e9.zip
mvebu: cortexa9: disable devices using broken mv88e6176 switch
Several users have reported, that devices using mv88e6176 switch are seriously broken, basically turning that switch into a hub. Until fixed those devices should be disabled. I've used TOH with "Switch 88E6176" filter, which provided me with the following list of likely affected devices: * Linksys WRT1200AC v1/v2, WRT1900AC v1/v2 * SolidRun ClearFog Pro * Turris Omnia That device list more or less corresponds with the list of devices mentioned in the linked bug reports. References: https://github.com/openwrt/openwrt/issues/11077 Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--target/linux/mvebu/image/cortexa9.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index d9738903fb..ac83e62e8a 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -66,6 +66,7 @@ define Device/cznic_turris-omnia
DEVICE_IMG_NAME = $$(2)
SUPPORTED_DEVICES += armada-385-turris-omnia
BOOT_SCRIPT := turris-omnia
+ DEFAULT := n
endef
TARGET_DEVICES += cznic_turris-omnia
@@ -114,6 +115,7 @@ define Device/linksys
IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
append-ubi | pad-to $$$$(PAGESIZE)
KERNEL_SIZE := 6144k
+ DEFAULT := n
endef
define Device/linksys_wrt1200ac
@@ -194,6 +196,7 @@ define Device/linksys_wrt32x
KERNEL_SIZE := 6144k
KERNEL := kernel-bin | append-dtb
SUPPORTED_DEVICES += armada-385-linksys-venom linksys,venom
+ DEFAULT := y
endef
TARGET_DEVICES += linksys_wrt32x
@@ -299,5 +302,6 @@ define Device/solidrun_clearfog-pro-a1
UBOOT := clearfog-u-boot-spl.kwb
BOOT_SCRIPT := clearfog
SUPPORTED_DEVICES += armada-388-clearfog armada-388-clearfog-pro
+ DEFAULT := n
endef
TARGET_DEVICES += solidrun_clearfog-pro-a1