aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Lam <david@thedavid.net>2021-09-19 22:42:14 -0700
committerStijn Tintel <stijn@linux-ipv6.be>2021-09-22 01:45:33 +0300
commit6a2f516d55a7782dd6882fa163e31a0ead70f70f (patch)
treebf4bc1e2070cf264961ef81ee4806421901432f6
parentb62a4cfc9330e9631a372a11fa9e09ac809080f5 (diff)
downloadupstream-6a2f516d55a7782dd6882fa163e31a0ead70f70f.tar.gz
upstream-6a2f516d55a7782dd6882fa163e31a0ead70f70f.tar.bz2
upstream-6a2f516d55a7782dd6882fa163e31a0ead70f70f.zip
6rd: delete tunnel on interface teardown
Delete tunnel on 6rd interface teardown. Should solve problem related to tunnel stuck on restart loop with "Unknown Command" on tunnel restart due to wan connection drop. This patch is similar to the one written by Ansuel on Aug 2, 2021 but the 6rd teardown produces the same symptoms when the network service is restarted. Signed-off-by: David Lam <david@thedavid.net>
-rw-r--r--package/network/ipv6/6rd/Makefile2
-rw-r--r--package/network/ipv6/6rd/files/6rd.sh2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/network/ipv6/6rd/Makefile b/package/network/ipv6/6rd/Makefile
index 9836ae9361..f9c4c6f7a5 100644
--- a/package/network/ipv6/6rd/Makefile
+++ b/package/network/ipv6/6rd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6rd
-PKG_RELEASE:=10
+PKG_RELEASE:=11
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/6rd/files/6rd.sh b/package/network/ipv6/6rd/files/6rd.sh
index 62a20314d9..3c913e54f1 100644
--- a/package/network/ipv6/6rd/files/6rd.sh
+++ b/package/network/ipv6/6rd/files/6rd.sh
@@ -82,6 +82,8 @@ proto_6rd_setup() {
proto_6rd_teardown() {
local cfg="$1"
+ local link="6rd-$cfg"
+ ip link del $link
}
proto_6rd_init_config() {