aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-08-25 16:30:52 +0000
committerJohn Crispin <john@openwrt.org>2014-08-25 16:30:52 +0000
commit1abdfe18efbc5598c70194a45b0250a24a9518cf (patch)
tree326f292c242a1444a108d582e85d443b32709200
parentc9813699b63c8df6d1b08d51b772cebee537d8cc (diff)
downloadupstream-1abdfe18efbc5598c70194a45b0250a24a9518cf.tar.gz
upstream-1abdfe18efbc5598c70194a45b0250a24a9518cf.tar.bz2
upstream-1abdfe18efbc5598c70194a45b0250a24a9518cf.zip
kernel: add ohci-platform.ko for 3.11+
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 42288
-rw-r--r--package/kernel/linux/modules/usb.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 96c899a8dd..0b5abdc335 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -331,7 +331,10 @@ define KernelPackage/usb-ohci
CONFIG_USB_OHCI_HCD_OMAP3=y \
CONFIG_USB_OHCI_HCD_PLATFORM=y
FILES:=$(LINUX_DIR)/drivers/usb/host/ohci-hcd.ko
- AUTOLOAD:=$(call AutoLoad,50,ohci-hcd,1)
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.11.0)),1)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ohci-platform.ko
+endif
+ AUTOLOAD:=$(call AutoLoad,50,ohci-hcd ohci-platform,1)
$(call AddDepends/usb)
endef