aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2022-03-27 23:15:48 +0200
committerDavid Bauer <mail@david-bauer.net>2022-10-14 23:15:30 +0200
commita7fb589e8a9df06bd0e36c91d05806f1e8aeb9e8 (patch)
treeaf90e7a9d6294ea06fff7e1f8ac3e3895fb3ddea
parent5db6914f7cfddd1c3cb8a46017d4360e1ec26c5d (diff)
downloadupstream-a7fb589e8a9df06bd0e36c91d05806f1e8aeb9e8.tar.gz
upstream-a7fb589e8a9df06bd0e36c91d05806f1e8aeb9e8.tar.bz2
upstream-a7fb589e8a9df06bd0e36c91d05806f1e8aeb9e8.zip
image: always rebuild kernel loaders
Kernel loaders like the lzma-loader currently don't track changes to their sources. This can lead to an old version of a loader to be used when a build tree is not clean between builds. As the loaders are tiny and the build times are insignificant, simply force rebuilding them on every build to avoid this problem. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> (cherry picked from commit a01d23e755ba46f41e667d558d82d4871d7f5450)
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 1703c39797..c7a2e082ab 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -524,7 +524,7 @@ endif
define Device/Build/compile
$$(_COMPILE_TARGET): $(KDIR)/$(1)
$(eval $(call Device/Export,$(KDIR)/$(1)))
- $(KDIR)/$(1):
+ $(KDIR)/$(1): FORCE
$$(call concat_cmd,$(COMPILE/$(1)))
endef