aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-08-07 14:30:53 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-08-16 12:22:17 +0100
commit98bccdafd7244238d9dfbbc1a342a4bb557e4b7c (patch)
tree729ed25e871db6e2648f546f81d4ee4b36902e2c
parent5c13177c55d068dec3e58f8f37c1c78502f73d3d (diff)
downloadupstream-98bccdafd7244238d9dfbbc1a342a4bb557e4b7c.tar.gz
upstream-98bccdafd7244238d9dfbbc1a342a4bb557e4b7c.tar.bz2
upstream-98bccdafd7244238d9dfbbc1a342a4bb557e4b7c.zip
base-files: rename 'sdcard' to 'legacy-sdcard'
While an image layout based on MBR and 'bootfs' partition may be easy to understand for users who are very used to the IBM PC and always have the option to access the SD card outside of the device (and hence don't really depend on other recovery methods or dual-boot), in my opinion it's a dead end for many desirable features on embedded systems, especially when managed remotely (and hence without an easy option to access the SD card using another device in case things go wrong, for example). Let me explain: * using a MSDOS/VFAT filesystem to store kernel(s) is problematic, as a single corruption of the bootfs can render the system into a state that it no longer boots at all. This makes dual-boot useless, or at least very tedious to setup with then 2 independent boot partitions to avoid the single point of failure on a "hot" block (the FAT index of the boot partition, written every time a file is changed in bootfs). And well: most targets even store the bootloader environment in a file in that very same FAT filesystem, hence it cannot be used to script a reliable dual-boot method (as loading the environment itself will already fail if the filesystem is corrupted). * loading the kernel uImage from bootfs and using rootfs inside an additional partition means the bootloader can only validate the kernel -- if rootfs is broken or corrupted, this can lead to a reboot loop, which is often a quite costly thing to happen in terms of hardware lifetime. * imitating MBR-boot behavior with a FAT-formatted bootfs partition (like IBM PC in the 80s and 90s) is just one of many choices on embedded targets. There are much better options with modern U-Boot (which is what we use and build from source for all targets booting off SD cards), see examples in mediatek/mt7622 and mediatek/mt7623. Hence rename the 'sdcard' feature to 'legacy-sdcard', and prefix functions with 'legacy_sdcard_' instead of 'sdcard_'. Tested-by: Stijn Tintel <stijn@linux-ipv6.be> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--package/base-files/Makefile10
-rw-r--r--package/base-files/files/lib/upgrade/legacy-sdcard.sh (renamed from package/base-files/files/lib/upgrade/sdcard.sh)6
-rwxr-xr-xscripts/target-metadata.pl2
-rw-r--r--target/Config.in2
-rw-r--r--target/linux/mvebu/Makefile2
-rwxr-xr-xtarget/linux/mvebu/cortexa53/base-files/lib/upgrade/platform.sh6
-rwxr-xr-xtarget/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh6
-rwxr-xr-xtarget/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh6
8 files changed, 20 insertions, 20 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index f19b07cfe1..d67f551b9c 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -23,7 +23,7 @@ PKG_LICENSE:=GPL-2.0
PKG_CONFIG_DEPENDS += \
CONFIG_SIGNED_PACKAGES CONFIG_TARGET_INIT_PATH CONFIG_TARGET_PREINIT_DISABLE_FAILSAFE \
CONFIG_NAND_SUPPORT \
- CONFIG_SDCARD_SUPPORT \
+ CONFIG_LEGACY_SDCARD_SUPPORT \
CONFIG_CLEAN_IPKG \
CONFIG_PER_FEED_REPO \
$(foreach feed,$(FEEDS_AVAILABLE),CONFIG_FEED_$(feed))
@@ -124,9 +124,9 @@ ifeq ($(CONFIG_NAND_SUPPORT),)
endef
endif
-ifeq ($(CONFIG_SDCARD_SUPPORT),)
- define Package/base-files/sdcard-support
- rm -f $(1)/lib/upgrade/sdcard.sh
+ifeq ($(CONFIG_LEGACY_SDCARD_SUPPORT),)
+ define Package/base-files/legacy-sdcard-support
+ rm -f $(1)/lib/upgrade/legacy-sdcard.sh
endef
endif
@@ -135,7 +135,7 @@ define Package/base-files/install
$(CP) ./files/* $(1)/
$(Package/base-files/install-key)
$(Package/base-files/nand-support)
- $(Package/base-files/sdcard-support)
+ $(Package/base-files/legacy-sdcard-support)
if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
$(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
fi
diff --git a/package/base-files/files/lib/upgrade/sdcard.sh b/package/base-files/files/lib/upgrade/legacy-sdcard.sh
index 2052805acb..d2ae53b729 100644
--- a/package/base-files/files/lib/upgrade/sdcard.sh
+++ b/package/base-files/files/lib/upgrade/legacy-sdcard.sh
@@ -1,4 +1,4 @@
-sdcard_check_image() {
+legacy_sdcard_check_image() {
local file="$1"
local diskdev partdev diff
@@ -26,7 +26,7 @@ sdcard_check_image() {
fi
}
-sdcard_do_upgrade() {
+legacy_sdcard_do_upgrade() {
local board=$(board_name)
local diskdev partdev diff
@@ -78,7 +78,7 @@ sdcard_do_upgrade() {
sleep 1
}
-sdcard_copy_config() {
+legacy_sdcard_copy_config() {
local partdev
if export_partdevice partdev 1; then
diff --git a/scripts/target-metadata.pl b/scripts/target-metadata.pl
index 34fb32a07e..163eb3768b 100755
--- a/scripts/target-metadata.pl
+++ b/scripts/target-metadata.pl
@@ -22,6 +22,7 @@ sub target_config_features(@) {
/^gpio$/ and $ret .= "\tselect GPIO_SUPPORT\n";
/^jffs2$/ and $ret .= "\tselect USES_JFFS2\n";
/^jffs2_nand$/ and $ret .= "\tselect USES_JFFS2_NAND\n";
+ /^legacy-sdcard$/ and $ret .= "\tselect LEGACY_SDCARD_SUPPORT\n";
/^low_mem$/ and $ret .= "\tselect LOW_MEMORY_FOOTPRINT\n";
/^minor$/ and $ret .= "\tselect USES_MINOR\n";
/^mips16$/ and $ret .= "\tselect HAS_MIPS16\n";
@@ -36,7 +37,6 @@ sub target_config_features(@) {
/^rfkill$/ and $ret .= "\tselect RFKILL_SUPPORT\n";
/^rootfs-part$/ and $ret .= "\tselect USES_ROOTFS_PART\n";
/^rtc$/ and $ret .= "\tselect RTC_SUPPORT\n";
- /^sdcard$/ and $ret .= "\tselect SDCARD_SUPPORT\n";
/^separate_ramdisk$/ and $ret .= "\tselect USES_INITRAMFS\n\tselect USES_SEPARATE_INITRAMFS\n";
/^small_flash$/ and $ret .= "\tselect SMALL_FLASH\n";
/^spe_fpu$/ and $ret .= "\tselect HAS_SPE_FPU\n";
diff --git a/target/Config.in b/target/Config.in
index fde7ea4137..32242446ee 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -101,7 +101,7 @@ config RFKILL_SUPPORT
config NAND_SUPPORT
bool
-config SDCARD_SUPPORT
+config LEGACY_SDCARD_SUPPORT
bool
config ARCH_64BIT
diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
index 6b992f8903..3737a4aa23 100644
--- a/target/linux/mvebu/Makefile
+++ b/target/linux/mvebu/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
BOARD:=mvebu
BOARDNAME:=Marvell EBU Armada
-FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part sdcard
+FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part legacy-sdcard
SUBTARGETS:=cortexa9 cortexa53 cortexa72
KERNEL_PATCHVER:=5.4
diff --git a/target/linux/mvebu/cortexa53/base-files/lib/upgrade/platform.sh b/target/linux/mvebu/cortexa53/base-files/lib/upgrade/platform.sh
index 26bb022415..0ee1d61506 100755
--- a/target/linux/mvebu/cortexa53/base-files/lib/upgrade/platform.sh
+++ b/target/linux/mvebu/cortexa53/base-files/lib/upgrade/platform.sh
@@ -15,7 +15,7 @@ platform_check_image() {
globalscale,espressobin-ultra|\
globalscale,espressobin-v7|\
globalscale,espressobin-v7-emmc)
- sdcard_check_image "$1"
+ legacy_sdcard_check_image "$1"
;;
*)
return 0
@@ -31,7 +31,7 @@ platform_do_upgrade() {
globalscale,espressobin-ultra|\
globalscale,espressobin-v7|\
globalscale,espressobin-v7-emmc)
- sdcard_do_upgrade "$1"
+ legacy_sdcard_do_upgrade "$1"
;;
methode,udpu)
platform_do_upgrade_uDPU "$1"
@@ -49,7 +49,7 @@ platform_copy_config() {
globalscale,espressobin-ultra|\
globalscale,espressobin-v7|\
globalscale,espressobin-v7-emmc)
- sdcard_copy_config
+ legacy_sdcard_copy_config
;;
methode,udpu)
platform_copy_config_uDPU
diff --git a/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh b/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
index 1713f55b72..74aad434ea 100755
--- a/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
+++ b/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
@@ -11,7 +11,7 @@ platform_check_image() {
case "$(board_name)" in
marvell,armada8040-mcbin-doubleshot|\
marvell,armada8040-mcbin-singleshot)
- sdcard_check_image "$1"
+ legacy_sdcard_check_image "$1"
;;
*)
return 0
@@ -23,7 +23,7 @@ platform_do_upgrade() {
case "$(board_name)" in
marvell,armada8040-mcbin-doubleshot|\
marvell,armada8040-mcbin-singleshot)
- sdcard_do_upgrade "$1"
+ legacy_sdcard_do_upgrade "$1"
;;
*)
default_do_upgrade "$1"
@@ -34,7 +34,7 @@ platform_copy_config() {
case "$(board_name)" in
marvell,armada8040-mcbin-doubleshot|\
marvell,armada8040-mcbin-singleshot)
- sdcard_copy_config
+ legacy_sdcard_copy_config
;;
esac
}
diff --git a/target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh b/target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh
index bf3961c437..5e69374837 100755
--- a/target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh
+++ b/target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh
@@ -13,7 +13,7 @@ platform_check_image() {
kobol,helios4|\
solidrun,clearfog-base-a1|\
solidrun,clearfog-pro-a1)
- sdcard_check_image "$1"
+ legacy_sdcard_check_image "$1"
;;
*)
return 0
@@ -30,7 +30,7 @@ platform_do_upgrade() {
kobol,helios4|\
solidrun,clearfog-base-a1|\
solidrun,clearfog-pro-a1)
- sdcard_do_upgrade "$1"
+ legacy_sdcard_do_upgrade "$1"
;;
linksys,wrt1200ac|\
linksys,wrt1900ac-v1|\
@@ -51,7 +51,7 @@ platform_copy_config() {
kobol,helios4|\
solidrun,clearfog-base-a1|\
solidrun,clearfog-pro-a1)
- sdcard_copy_config
+ legacy_sdcard_copy_config
;;
linksys,wrt1200ac|\
linksys,wrt1900ac-v1|\