aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2022-07-17 17:56:36 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-03 17:40:26 +0200
commit65bd63206900c0660ac5eb9465a4ffdacb9e51ec (patch)
tree562a2e4a0304eef083ad19805c41334f6e84ee58
parentb0622d1221281babcb4fa6901becff0ee9bfe6ab (diff)
downloadupstream-65bd63206900c0660ac5eb9465a4ffdacb9e51ec.tar.gz
upstream-65bd63206900c0660ac5eb9465a4ffdacb9e51ec.tar.bz2
upstream-65bd63206900c0660ac5eb9465a4ffdacb9e51ec.zip
scripts: ext-toolchain: add support for info.mk in probe_cc
Openwrt generate info.mk that contains the libc type. For probe_cc check if the file exist and parse directly it for LIBC type. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com> (cherry picked from commit 75311977f5ff64b491cb57ac713d75e0e410d786)
-rwxr-xr-xscripts/ext-toolchain.sh7
1 files changed, 7 insertions, 0 deletions
diff --git a/scripts/ext-toolchain.sh b/scripts/ext-toolchain.sh
index 1ef3f42c50..1f8eca3076 100755
--- a/scripts/ext-toolchain.sh
+++ b/scripts/ext-toolchain.sh
@@ -463,6 +463,13 @@ probe_cpp() {
}
probe_libc() {
+ if [ -f $TOOLCHAIN/info.mk ]; then
+ LIBC_TYPE=$(grep LIBC_TYPE $TOOLCHAIN/info.mk | sed 's/LIBC_TYPE=//')
+ return 0
+ fi
+
+ echo "Warning! Can't find info.mk, trying to detect with alternative way."
+
if [ -z "$LIBC_TYPE" ]; then
if test_uclibc; then
LIBC_TYPE="uclibc"