aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Wegener <sven.wegener@stealer.net>2021-05-01 13:51:51 +0200
committerDaniel Golle <daniel@makrotopia.org>2022-09-18 15:40:04 +0100
commitf54d4ea0bb41fb7285b35bde9984ce07679b4954 (patch)
tree75aa69115bdfc8fbfc1f52fdc50c9a003cf199dd
parenta28ccd58ed56e53726a2ca7844ab11d043ce973a (diff)
downloadupstream-f54d4ea0bb41fb7285b35bde9984ce07679b4954.tar.gz
upstream-f54d4ea0bb41fb7285b35bde9984ce07679b4954.tar.bz2
upstream-f54d4ea0bb41fb7285b35bde9984ce07679b4954.zip
ramips: add support for Ubiquiti UniFi FlexHD
Hardware -------- - SoC: MediaTek MT7621AT with 128 MiB RAM and 32 MiB Flash - Wi-Fi: MediaTek MT7603 (b/g/n, 2x2) and MediaTek MT7615 (ac, 4x4) - Bluetooth: CSR8811 (internal USB, install kmod-bluetooth) Installation ------------ 1. Connect to the booted device at 192.168.1.20 using username/password "ubnt". 2. Update the bootloader environment. $ fw_setenv devmode TRUE $ fw_setenv boot_openwrt "fdt addr \$(fdtcontroladdr); fdt rm /signature; bootubnt" $ fw_setenv bootcmd "run boot_openwrt" 3. Transfer the OpenWrt sysupgrade image to the device using SCP. 4. Check the mtd partition number for bs / kernel0 / kernel1 $ cat /proc/mtd 5. Set the bootselect flag to boot from kernel0 $ dd if=/dev/zero bs=1 count=1 of=/dev/mtdblock4 6. Write the OpenWrt sysupgrade image to both kernel0 as well as kernel1 $ dd if=openwrt.bin of=/dev/mtdblock6 $ dd if=openwrt.bin of=/dev/mtdblock7 7. Reboot the device. It should boot into OpenWrt. Signed-off-by: Sven Wegener <sven.wegener@stealer.net> (cherry picked from commit 820f0c07c544652c1c53a45262a481ac5dbe139b)
-rw-r--r--target/linux/ramips/dts/mt7621_ubnt_unifi-flexhd.dts181
-rw-r--r--target/linux/ramips/image/mt7621.mk11
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/mt7621/config-5.101
4 files changed, 194 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7621_ubnt_unifi-flexhd.dts b/target/linux/ramips/dts/mt7621_ubnt_unifi-flexhd.dts
new file mode 100644
index 0000000000..615bdf4e13
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_ubnt_unifi-flexhd.dts
@@ -0,0 +1,181 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "ubnt,unifi-flexhd", "mediatek,mt7621-soc";
+ model = "Ubiquiti UniFi FlexHD";
+
+ aliases {
+ label-mac-device = &gmac0;
+ led-boot = &led_blue;
+ led-failsafe = &led_blue;
+ led-running = &led_blue;
+ led-upgrade = &led_blue;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <50000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x60000>;
+ read-only;
+ };
+
+ partition@60000 {
+ label = "u-boot-env";
+ reg = <0x60000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@70000 {
+ label = "factory";
+ reg = <0x70000 0x10000>;
+ read-only;
+ };
+
+ eeprom: partition@80000 {
+ label = "eeprom";
+ reg = <0x80000 0x10000>;
+ read-only;
+ };
+
+ partition@90000 {
+ label = "bs";
+ reg = <0x90000 0x10000>;
+ };
+
+ partition@a0000 {
+ label = "cfg";
+ reg = <0xa0000 0x100000>;
+ read-only;
+ };
+
+ partition@1a0000 {
+ compatible = "denx,fit";
+ label = "firmware";
+ reg = <0x1a0000 0xf30000>;
+ };
+
+ partition@10d0000 {
+ label = "kernel1";
+ reg = <0x10d0000 0xf30000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&eeprom {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_eeprom_0: macaddr@0 {
+ reg = <0x0 0x6>;
+ };
+};
+
+&gmac0 {
+ nvmem-cells = <&macaddr_eeprom_0>;
+ nvmem-cell-names = "mac-address";
+};
+
+&switch0 {
+ ports {
+ port@0 {
+ status = "okay";
+ label = "lan";
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ reg = <0x0 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0>;
+ // On newer devices there is a MediaTek MAC in the above
+ // device EEPROM, so override it with a calculated one.
+ nvmem-cells = <&macaddr_eeprom_0>;
+ nvmem-cell-names = "mac-address";
+ mac-address-increment = <1>;
+ };
+};
+
+&pcie1 {
+ wifi@0,0 {
+ reg = <0x0 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ // On newer devices there is a MediaTek MAC in the above
+ // device EEPROM, so override it with a calculated one.
+ nvmem-cells = <&macaddr_eeprom_0>;
+ nvmem-cell-names = "mac-address";
+ mac-address-increment = <2>;
+ };
+};
+
+&i2c {
+ status = "okay";
+ clock-frequency = <400000>;
+
+ led-controller@30 {
+ compatible = "ubnt,ledbar";
+ reg = <0x30>;
+
+ enable-gpio = <&gpio 44 GPIO_ACTIVE_HIGH>;
+ reset-gpio = <&gpio 41 GPIO_ACTIVE_LOW>;
+ led-count = <8>;
+
+ red {
+ label = "red";
+ };
+
+ green {
+ label = "green";
+ };
+
+ led_blue: blue {
+ label = "blue";
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "uart2";
+ function = "gpio";
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 7f903485aa..8860be11b8 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1785,6 +1785,17 @@ define Device/ubnt_unifi-6-lite
endef
TARGET_DEVICES += ubnt_unifi-6-lite
+define Device/ubnt_unifi-flexhd
+ $(Device/dsa-migration)
+ DEVICE_VENDOR := Ubiquiti
+ DEVICE_MODEL := UniFi FlexHD
+ DEVICE_DTS_CONFIG := config@2
+ KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ DEVICE_PACKAGES += kmod-mt7603 kmod-mt7615e kmod-mt7615-firmware
+ IMAGE_SIZE := 15552k
+endef
+TARGET_DEVICES += ubnt_unifi-flexhd
+
define Device/ubnt_unifi-nanohd
$(Device/dsa-migration)
DEVICE_VENDOR := Ubiquiti
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index 2a08aded34..ad560a4ec0 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -20,6 +20,7 @@ ramips_setup_interfaces()
tplink,re650-v1|\
tplink,re650-v2|\
ubnt,unifi-6-lite|\
+ ubnt,unifi-flexhd|\
ubnt,unifi-nanohd)
ucidef_set_interface_lan "lan"
;;
diff --git a/target/linux/ramips/mt7621/config-5.10 b/target/linux/ramips/mt7621/config-5.10
index ec6822fa6d..dd23f13bc6 100644
--- a/target/linux/ramips/mt7621/config-5.10
+++ b/target/linux/ramips/mt7621/config-5.10
@@ -111,6 +111,7 @@ CONFIG_IRQ_MIPS_CPU=y
CONFIG_IRQ_WORK=y
# CONFIG_KERNEL_ZSTD is not set
CONFIG_LED_TRIGGER_PHY=y
+CONFIG_LEDS_UBNT_LEDBAR=y
CONFIG_LIBFDT=y
CONFIG_LOCK_DEBUGGING_SUPPORT=y
CONFIG_LZO_COMPRESS=y