diff options
author | Syrone Wong <wong.syrone@gmail.com> | 2018-07-26 22:38:57 +0800 |
---|---|---|
committer | Felix Fietkau <nbd@nbd.name> | 2018-08-20 09:24:29 +0200 |
commit | 713cee6463a8b654d2c72e469112130373c1336b (patch) | |
tree | 3ccf98b6c2c0e1e7ebcc3e943cb4b9f1aaf6bb23 | |
parent | fc9cbf3bc0673c97e31693ea45fad1798346c2cd (diff) | |
download | upstream-713cee6463a8b654d2c72e469112130373c1336b.tar.gz upstream-713cee6463a8b654d2c72e469112130373c1336b.tar.bz2 upstream-713cee6463a8b654d2c72e469112130373c1336b.zip |
toolchain/gcc: add config symbol to determine how to apply path remapping
Added boolean symbol for GCC 8 and higher, when we add newer GCC, we don't have
to modify rules.mk to keep things consistant.
Fixes: da9d760 ("rules.mk: replace iremap when using GCC 8")
Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
-rw-r--r-- | rules.mk | 6 | ||||
-rw-r--r-- | toolchain/gcc/Config.version | 5 |
2 files changed, 8 insertions, 3 deletions
@@ -140,10 +140,10 @@ else endif ifeq ($(or $(CONFIG_EXTERNAL_TOOLCHAIN),$(CONFIG_GCC_VERSION_4_8),$(CONFIG_TARGET_uml)),) - iremap = -iremap$(1):$(2) - # just overwrite iremap for GCC 8.1 and higher to keep backward compatibility - ifeq ($(CONFIG_GCC_VERSION_8),y) + ifeq ($(CONFIG_GCC_USE_EMBEDDED_PATH_REMAP),y) iremap = -fmacro-prefix-map=$(1)=$(2) + else + iremap = -iremap$(1):$(2) endif endif diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version index 97c5e50dad..6413e85219 100644 --- a/toolchain/gcc/Config.version +++ b/toolchain/gcc/Config.version @@ -10,6 +10,11 @@ config GCC_VERSION_8 default y if GCC_USE_VERSION_8 bool +config GCC_USE_EMBEDDED_PATH_REMAP + default y if GCC_VERSION_8 + default n + bool + config GCC_VERSION string default "5.5.0" if GCC_VERSION_5 |