aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-09-11 08:15:52 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-09-29 19:37:35 +0200
commit463fe05d9e6e2cd2b08573db325105ce132eff24 (patch)
tree96444728bc75a411400a30e41c6f24407a965fb0
parent25d8b9cad6f141104a1065880efe21b8c292d8c6 (diff)
downloadupstream-463fe05d9e6e2cd2b08573db325105ce132eff24.tar.gz
upstream-463fe05d9e6e2cd2b08573db325105ce132eff24.tar.bz2
upstream-463fe05d9e6e2cd2b08573db325105ce132eff24.zip
Makefile: fix stray \ warnings with grep-3.8
We simply grep for "/usr". So no need for "-E" or "\/". Furthermore, in the new grep versions this creates warnings. As written in the grep-3.8 announcement: Regular expressions with stray backslashes now cause warnings, as their unspecified behavior can lead to unexpected results. For example, '\a' and 'a' are not always equivalent <https://bugs.gnu.org/39678>. Fixes warnings in the form of: grep: warning: stray \ before / Signed-off-by: Nick Hainke <vincent@systemli.org> (cherry picked from commit a29d3bc48c40c6a2a93ae1806bea2ac26455cdbb) [ fix conflict error ] Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 3ac110367d..a3085ae0c8 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
world:
-DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -E '\/usr' | head -n 1)
+DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep '/usr' | head -n 1)
export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
ifneq ($(OPENWRT_BUILD),1)