aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2022-06-14 15:54:48 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2022-07-01 13:39:01 +0300
commitc7673625d9b29d99c32e4ae1b9c15a7d4faebd9e (patch)
treebdc8b285fc65ecee26abb920650e980fe47464f1
parentd6a06e1d1801449f4e83f47ace2c0866206f564c (diff)
downloadupstream-c7673625d9b29d99c32e4ae1b9c15a7d4faebd9e.tar.gz
upstream-c7673625d9b29d99c32e4ae1b9c15a7d4faebd9e.tar.bz2
upstream-c7673625d9b29d99c32e4ae1b9c15a7d4faebd9e.zip
qoriq: define leds for Firebox M300
This patch provides support for the Firebox M300 only user-controllable bi-color LED, and makes the green "shield" LED act as the typical OpenWrt status led. Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org> (cherry picked from commit 4ab421b81d383c127135716f56a1e18337575516)
-rw-r--r--target/linux/qoriq/files/arch/powerpc/boot/dts/fsl/watchguard-firebox-m300.dts21
-rw-r--r--target/linux/qoriq/image/generic.mk2
2 files changed, 22 insertions, 1 deletions
diff --git a/target/linux/qoriq/files/arch/powerpc/boot/dts/fsl/watchguard-firebox-m300.dts b/target/linux/qoriq/files/arch/powerpc/boot/dts/fsl/watchguard-firebox-m300.dts
index 54f7e06bc5..4ba30a3c0f 100644
--- a/target/linux/qoriq/files/arch/powerpc/boot/dts/fsl/watchguard-firebox-m300.dts
+++ b/target/linux/qoriq/files/arch/powerpc/boot/dts/fsl/watchguard-firebox-m300.dts
@@ -7,6 +7,8 @@
* Copyright 2020 - 2021 Stijn Tintel <stijn@linux-ipv6.be>
*/
+#include <dt-bindings/gpio/gpio.h>
+
/include/ "t208xsi-pre.dtsi"
/include/ "t208xqds.dtsi"
@@ -31,6 +33,11 @@
ethernet2 = &enet1;
ethernet3 = &enet2;
ethernet4 = &enet3;
+
+ led-boot = &led_shield;
+ led-failsafe = &led_shield;
+ led-running = &led_shield;
+ led-upgrade = &led_shield;
};
};
@@ -325,4 +332,18 @@
status = "disabled";
};
};
+
+ leds {
+ compatible = "gpio-leds";
+
+ shield-red {
+ label = "red:shield";
+ gpios = <&gpio0 28 GPIO_ACTIVE_HIGH>;
+ };
+
+ led_shield: shield-green {
+ label = "green:shield";
+ gpios = <&gpio0 29 GPIO_ACTIVE_HIGH>;
+ };
+ };
};
diff --git a/target/linux/qoriq/image/generic.mk b/target/linux/qoriq/image/generic.mk
index b8ffc69ba0..b2689850b3 100644
--- a/target/linux/qoriq/image/generic.mk
+++ b/target/linux/qoriq/image/generic.mk
@@ -6,7 +6,7 @@ define Device/watchguard_firebox-m300
DEVICE_COMPAT_VERSION := 1.1
DEVICE_DTS_DIR := $(DTS_DIR)/fsl
DEVICE_PACKAGES := \
- kmod-hwmon-w83793 kmod-ptp-qoriq kmod-rtc-rs5c372a kmod-tpm-i2c-atmel
+ kmod-hwmon-w83793 kmod-leds-gpio kmod-ptp-qoriq kmod-rtc-rs5c372a kmod-tpm-i2c-atmel
KERNEL := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
KERNEL_SUFFIX := -fit-uImage.itb
IMAGES := sdcard.img.gz sysupgrade.img.gz