aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudiu Beznea <claudiu.beznea@microchip.com>2022-07-13 09:19:33 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2022-07-31 17:12:47 +0200
commitc5f0eab222f1fe7df632b690fdcea97cab677c80 (patch)
tree9906a09ba224b515ea0872c692261e75ca301fda
parent972b833e9161697beacb4286c8c91aeeec1161fe (diff)
downloadupstream-c5f0eab222f1fe7df632b690fdcea97cab677c80.tar.gz
upstream-c5f0eab222f1fe7df632b690fdcea97cab677c80.tar.bz2
upstream-c5f0eab222f1fe7df632b690fdcea97cab677c80.zip
uboot-at91: fix build on buildbots
Buidbots are throwing the following compile error: In file included from tools/aisimage.c:9: include/image.h:1133:12: fatal error: openssl/evp.h: No such file or directory ^~~~~~~~~~~~~~~ compilation terminated. Fix it by passing `UBOOT_MAKE_FLAGS` variable to make. Suggested-by: Petr Štetiar <ynezz@true.cz> Fixes: 6d5611af2813 ("uboot-at91: update to linux4sam-2022.04") Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com> (cherry picked from commit 95a24b54792ccf072c029edad495deb529383478)
-rw-r--r--package/boot/uboot-at91/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 394cd7a42a..d75e3ba3af 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -175,7 +175,8 @@ define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CROSS_COMPILE=$(TARGET_CROSS) \
KCFLAGS="$(filter-out -fstack-protector \
- -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft"
+ -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft" \
+ $(UBOOT_MAKE_FLAGS)
endef
$(eval $(call BuildPackage/U-Boot))