aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2022-06-07 13:26:43 +0200
committerPaul Spooren <mail@aparcar.org>2022-07-29 15:12:49 +0200
commita409bd7705154045141e8fde408a33c19dfe9be9 (patch)
tree0a38c8a07f749bf05ed1b719d3950660cec01f83
parente0d3dc5de195d70f740178fe49b0928ca39ae58f (diff)
downloadupstream-a409bd7705154045141e8fde408a33c19dfe9be9.tar.gz
upstream-a409bd7705154045141e8fde408a33c19dfe9be9.tar.bz2
upstream-a409bd7705154045141e8fde408a33c19dfe9be9.zip
octeon: add SUPPORTED_DEVICES to er/erlite
Using the BOARD_NAME variable results for both er and erlite devices to identify themselfs as `er` and `erlite` (via `ubus call system board`). This is problematic when devices search for firmware upgrades since the OpenWrt profile is actually called `ubnt_edgerouter` and `ubnt_edgerouter-lite`. By adding the `SUPPORTED_DEVICE` a mapping is created to point devices called `er` or `erlite` to the corresponding profile. FIXES: https://github.com/openwrt/asu/issues/348 Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 2a07270180ed0e295d854d6e9e59c78c40549efc)
-rw-r--r--target/linux/octeon/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index f77159e1f9..23adb884f8 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -48,6 +48,7 @@ define Device/ubnt_edgerouter
DEVICE_MODEL := EdgeRouter
BOARD_NAME := er
CMDLINE := $(ER_CMDLINE)
+ SUPPORTED_DEVICES += er
endef
TARGET_DEVICES += ubnt_edgerouter
@@ -79,6 +80,7 @@ define Device/ubnt_edgerouter-lite
DEVICE_MODEL := EdgeRouter Lite
BOARD_NAME := erlite
CMDLINE := $(ERLITE_CMDLINE)
+ SUPPORTED_DEVICES += erlite
endef
TARGET_DEVICES += ubnt_edgerouter-lite